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Solveig Multimedia Video Splitter  

 
This documentation is designed to help you in using Solveig Multimedia Video Splitter. It contains information that 
describes basic and advanced steps for performing splitting tasks, interface items and shortcut keys. 
This documentation is divided into the following sections: 

 Getting started: This section contains introductory information about Solveig Multimedia Video Splitter, 
supported file formats, system requirements, basic terms and shortcut keys  

 Solveig Multimedia Video Splitter interface: Provides information about controls in the Solveig Multimedia 
Video Splitter user interface  

 Using Solveig Multimedia Video Splitter: Provides information about procedures to accomplish common 
tasks in Solveig Multimedia Video Splitter  

 How-To: Provides information about the basic steps of video splitting process  
 Technical information: Provides the technical description of the components Video Splitter is based on  

 

Notices 

SolveigMM Video Splitter  

User Guide 

 

Version 7  

SolveigMM Video Splitter User Guide 

First edition: August 18, 2005 

Date modified: June 07, 2019 

For information, contact Solveig Multimedia 

Tel: +7 382-2-488-585 ext. 2049; Fax: +1 (801) 991-5443 

 

More information can be found at: www.solveigmm.com 

For Technical Support, please contact the Solveig Multimedia Technical Support Team: support@solveigmm.com 

Solveig Multimedia provides this publication “as is” without warranty of any kind, either expressed or implied.  

This publication may contain technical inaccuracies or typographical errors. While every precaution has been taken 
in the preparation of this document, the publisher and author assume no responsibility for errors or omissions. Nor 
is any liability assumed for damages resulting from the use of the information contained herein. Changes are 
periodically made to the information herein; these changes will be incorporated in new editions of the publication. 
Solveig Multimedia may make improvements and/ or changes in the product(s) and/or the program(s) described in 
this publication at any time. 

http://www.solveigmm.com/
mailto:support@solveigmm.com
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Other company, product, service names and trademarks are trademarks or service marks of other companies or 
corporations.

 

Getting started  
 
SolveigMM Video Splitter is a fast and powerful video splitting tool (see supported file formats). You can split your 
video file into parts with a few mouse clicks without any quality loss. 
It is also possible to cut out several file portions of a movie at one time. You can get rid of all commercials in your 
movie in a couple of simple steps. 
 

Video Splitter supports batch processing. If you need to process several tasks at a time, the Batch Manager help 
with it. You can add all your trimming tasks to a batch queue and process all of them at a time. Batch processing 
is supported only in Video Splitter Business Edition.  

Join Manager of Video Splitter allows to join multiple audio/video fragments. The re-encoding is not involved in the 
joining process so all files must have the same parameters, such as video frame height/width, audio/video 
compression type, etc. 
 
The slicing feature of Video Splitter allows to split files in parts by specified duration, size and by number of equal 
parts.  
It is also possible to make the screenshot from the selected video frame.  
 
Since version 6 Video Splitter has flexible timeline with support of editing of multiple files being placed on the 
same timeline per one run. Simply add files of the same format to the list of files, drag them to the timeline, place 
markers and get the desired video or audio track. 
 
In this section:   

 Distinction between Home Edition and Business Edition: The explanation of difference between Video 
Splitter Home and Business Editions 

 Basic terms: The explanation of concepts and terms referred to in this document  
 Supported file formats: The list of file formats that SolveigMM Video Splitter can handle  
 System requirements: Minimum and recommended system requirements for SolveigMM Video Splitter  
 Keyboard shortcuts: The list of keyboard shortcuts  

 

Distinction between Home Edition and Business Edition 
 
SolveigMM Video Splitter is available in two editions, Home Edition and Business Edition.  
You can compare these editions in the table below. 

Feature SolveigMM Video Splitter 
Home Edition 

SolveigMM Video Splitter  
Business Edition 

Batch Manager. Unlimited number of editing 
tasks in one run  

✔ 

Command line interface (SolveigMM Batch 
Splitter console utility)  

✔ 

 

Basic terms 
 
This section explains the key terms referred to throughout this document. Understanding these terms will help you 
start using Solveig Multimedia Movie Splitter in the most comfortable way. 
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 Splitting process  
 Joining process  
 Source and destination files  
 Markers  
 Fragments  

 

Splitting process 

Splitting is the process of dividing your video files into parts. For example, you can cut out a piece of video with 
undesired scenes (e.g. commercials, corrupted video). The splitting process leaves source files intact saving the 
result in the destination file. 

 

Joining process 

Joining is the process of combining multiple parts or fragments of video/audio into a single file. Joining does not 
involve re-encoding so it does not affect the output audio/video quality. 

 
Source and destination files 
 
The source and destination files are the video files of a supported format. The source file contains video that you 
can split into parts, the destination file contains the final movie clip. During the splitting process, the source file 
remains in its original location and will not be changed or deleted. 

 

Markers 

 
A marker is a constituent part of a fragment. A fragment consists of two markers: start and end. It is set in the 
current cursor position. 
 
The blue color means that the marker is selected. If marker is not selected it has the white color. 
 
Such operations as deleting and positioning are applied to selected markers only. 
 

 

Selected state Not selected state 
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Fragments 

 

A fragment is a part of a movie (or audio) file limited by two markers that is to be removed or kept in the final 

movie, e.g. the commercial block you need to be cut out. 

The cut out fragment is usually highlighted with the red color. 

You can see a sample keept and cut out fragments in the selected and not selected state below. 

 

In case of some marker's time position corrections, you could deploy the collapsed fragment by double clicking on 

it. 

Selected state  Not selected state 

Keept fragment Cut out fragment 
Collapsed 

fragment 
Keept fragment Cut out fragment 

Collapsed 

fragment 

      

 
For more detailed color definition see Using splitting controls section.  

 

Supported file formats 

 

- SolveigMM Video Splitter supports the following media file formats: 

 

H.265  
 
video elementary stream 
in MP4/TS/MKV 

H.264  
 
video elementary 
stream 
in MP4/TS/MKV/AVI 

MPEG-2  
 
video elementary 
stream 
in PS / TS 

MP4 ISO Format  
 
with H265 / AAC 
with H264 / AAC 
other video/audio 

AVCHD Format 

MPEG TS Format  
 
with H265 / audio (AC3, 
AAC) 
with H264 / audio (AC3, 
AAC)  

MOV Format 
 
with H264 / AAC 
other video/audio 

AVI Format 
 
DV AVI type 1, type 
2 
OpenDML AVI 
any video/audio type 
any size > 2GB, > 

4GB 

ASF Format 
 
any 3rd party 
video/audio type 

Matroska 
Format 
 
with H264 / 
AAC 
with H265 / 
audio 

other video / 
audio 

WEBM Format WMV Format MPEG-1  FLV Format Audio 
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VP8 Video 
Vorbis Audio 

 
any Windows Media 
Video 
any Windows Media 
Audio 

 
System stream 
Video elementary 
stream 
Audio elementary 
stream 

 
H264 Video 
AAC Audio 

 
mp3 
mp1 
aac 
ac3 

 

- Indexation supports the following file formats:  

- MPEG-1 Video Format files (*.mpg, *.mpeg, *.m1v, *.mpv) 
 
- MPEG-2 Video Format files (*.mpg, *.mpeg, *.mpv, *.m2v, *.vob, *.ts, *.m2ts, *.vob) 

- Support of embedded subtitles of formats (*):  
 
- UTF8  
 
- ASS 
 
- SSA 
 
- GAB2 

 
- Support of external subtitles of formats (**):  

- ASS 
 
- SRT 

(*) - Available for file formats: AVI, MKV, WEBM 

(**) - Available for file formats: AVI, MKV, WEBM, MP4 

 
 

System requirements 

 

Software Requirements  

 Windows® 98/ Me / 2000 / XP / 7 / 8 / 10 
 DirectX 8.0 Runtime or higher  
 Video and audio decoders for the preview feature (DirectShow, VFW or DMO)  
 WMV/ASF support requires Windows Media Format 9 Series Runtime (shipped with Windows Media Player 

9 and higher) MS: https://support.microsoft.com/en-gb/help/14209/get-windows-media-player  
 Windows Media Format 11 Series Runtime for WMV file frame accurate editing https://www.free-

codecs.com/download/windows_media_format_11.htm 
 
Hardware Requirements  

 CPU (Intel® Pentium II, Celeron, AMD® Athlon, Opteron etc.)  
 128 MB RAM  
 Any VGA card  
 About 110 MB of free disk space  

https://support.microsoft.com/en-gb/help/14209/get-windows-media-player
https://www.free-codecs.com/download/windows_media_format_11.htm
https://www.free-codecs.com/download/windows_media_format_11.htm
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Keyboard shortcuts 

 
Almost every procedure in SolveigMM Video Splitter can be done using shortcut keys. Using these shortcut keys 
you can do some tasks more quickly. 
The table below provides the list of operations that you can perform using keyboard shortcuts. 

Hot Keys of Video Splitter (main window): 

Operation Shortcut key 

Add Marker M 

Clear All Markers Ctrl + C 

Cut Out Previous Fragment F 

Cut out Selected Fragment D 

Invert Time Line Fragments I 

Keep Selected Fragment S 

Play/Pause Space 

Redo Ctrl + Y 

Remove Marker(s) Delete 

Save... Ctrl + T 

Undo Ctrl + Z 

Close Ctrl + W 

Open Media File Ctrl + O 

Save Project Ctrl + S 

Jump 1/20th Backward Page Down 

Jump 1/20th Forward Page Up 

Jump 2 min Backward Shift + Left 

Jump 2 min Forward Shift + Right 

Jump to Movie End End 

Jump to Movie Start Home 

Next Frame Ctrl + Right 

Next K Frame Right 

Previous Frame Ctrl + Left 

Previous K Frame Left 

Select Next Marker Tab 

Select Previous Marker Shift + Tab 

Select Slider Cursor Ctrl + Tab 

Preferences Ctrl + P 

Maximize Zoom Num / 

Move Scaled Area Left Alt + Left 

Move Scaled Area Right Alt + Right 

Reset Zoom Num* 

Zoom In Num+ 

Zoom Out Num- 

Hot Keys of Batch Manager:  

Operation Shortcut key 

Add Task to Batch Queue A 
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Delete Selected Fragment  Shift + Delete  

Delete Selected Task(s) Delete  

Start Batch processing Ctrl + T  

Start Barch Processing For Selected Task(s) Shift + T 

Update Task U  

Load Batch List Ctrl + O  

Edit the task in main window or show the selected 
fragment in the main window  

Enter 

Select all tasks Ctrl + A 

 
 
Hot Keys of Join Manager:  

Operation Shortcut key 

Add media file(s) to the list  Ins  

Delete the selected files from list Del  

Move the selected item down  PgDown  

Move the selected item up  PgUp  

Solveig Multimedia Video Splitter interface 

The Solveig Multimedia Video Splitter user interface consist of five main parts: Menu bar, Navigation controls, 

Information window, Splitter controls and Preview window. 

SolveigMM Video Splitter main window:  
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In this section:  

 Menu bar 
 Stream selection window   
 Navigation controls 
 Media panel  
 Splitting controls  
 Preview window  
 Progress window  
 Splitter in system tray  
 Filters info window  
 Batch manager  
 Join manager 
 Slicing Window 
 Stream selection window 
 Preferences window  

 

Menu bar 
 

You can use commands in the menu bar to perform tasks in Solveig Multimedia Video Splitter. These commands 
are described in this document. 
 

 
 
File menu 
 

 

 

mk:@MSITStore:G:/portable/splitter/!%208%20мая%202020/SMMVSplitterBusinessPortable/Lang_Splitter/eng.chm::/SRC/interface.html#stream_selection
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Menu item Description Shortcut key 

Add Media Files... 
Select a supported media file to be opened and edited 
(*) 

Ctrl + O 

Save Media File As... 
Specify the output file name and immediately save it 
(start the trimming process)  (*)  

Save Selected Fragment As... 
Specify the output file name and immediately save it 
(start the trimming process) (*)  

Save All Fragments As... 
Specify the output file name and immediately save 
all fragments (start the trimming process) (*)  

Close Close the input and output files  Ctrl + W 

Load project... Open a SolveigMM Video Splitter project file  
 

Save project Save the project file Ctrl + S 

Save project As... Save the project file to the specified folder 
 

Load Batch List... Load a task list to the Batch Manager 
 

Save Batch List Save the batch list 
 

Save Batch List As... Save the batch list to the specified folder 
 

Load Join List... Load a join list to the Join Manager 
 

Save Join List Save the join list 
 

Save Join List As... Save the join list to the specified folder 
 

Recent Files... Open the recently edited files 
 

Exit Close the program 
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File menu -> Recent Files 

 

 

Menu item Description 

Clear History Allows to clear history of recent files 

 

Edit menu 

 
 

Menu item  Description  Shortcut key  

Undo (Add Marker)  Undo the action  Ctrl + Z 

Redo  Redo the action  Ctrl + Y  

Stop  Stop playback  
 

Play  Start playback  Space  

Pause  Pause playback  Space  

Add Marker  Add a marker  M  

Remove Marker(s)  Remove the selected marker or markers (*)  Delete  

Keep Selected Fragment  Keep the selected fragment (*)  S  

Cut Out Selected Fragment  Cut the selected fragment (*)  D  

Cut Out Previous Fragment  Cut out the previous fragment (*)  F  

Clear All Markers  Remove all markers   Ctrl + C  
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Invert Time Line Fragment  Invert all timeline fragments on the slider (*)  I  

Start trimming  Start the trimming process (*) Ctrl + T  

Slicing...  Opens slicing window  
 

Set audio silence  Allows to mute sound of the selected fragment  
 

 
(*) - These operations are available from the menu and from the context menu . For details, see Navigation 
controls, Splitting controls 

View menu 

 

Menu item Description Shortcut key 

Time format Opens the submenu - 

Show frames thumbnails Allows to show or hide frames thumbnails - 

Show format switch 
warnings 

Allows to turn off or turn on format switch warnings - 

Zoom Opens the submenu - 

Languages Opens the submenu language of interface selecting - 

Panels Opens the submenu - 

Maps Opens the submenu - 

Show audio waveform Allows to show or hide audio waveform - 

View menu -> Time format 
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Menu item Description Shortcut key 

Times and frames Allows to show timeline in HH:MM:SS;frames format - 

Time Allows to show timeline in HH:MM:SS;ms format - 

 

View menu -> Zoom  

 

Menu item Description Shortcut key 

Move Scaled Area Right Move the zooming scrollbar right Alt + Right Arrow 

Move Scaled Area Left Move the zooming scrollbar left Alt + Right Arrow 

Zoom In Zoom in the timeline slider NumPad + 

Zoom Out Zoom out the timeline slider NumPad - 

Maximize Zoom Set the max scale rate  NumPad / 

Reset Zoom Reset the scale rate to 1 (initial scale) NumPad * 

View menu -> Panels 

 

Menu item Description 

Input/Output information Shows information about input and output files 

GPS navigation Shows GPS information if file contains such 

GPS navigation sensors 
Shows GPS navigation sensors: speedometer, compass and accelerometer (if file 
contains such information) 
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View menu -> Maps 
 

 

 

Menu item Description 

Yandex maps Displays route on the Yandex maps (if file contains such information) 

 

Navigation menu 
 

 

 

Menu item Description Shortcut key 

Next K Frame Go to the next K Frame Right Arrow 

Previous K Frame Go to the previous K Frame Left Arrow 

Next Frame Go to the next Frame Ctrl + Right Arrow 

Previous Frame Go to the previous Frame Ctrl + Left Arrow 

Jump 2 min Forward Jump 2 minutes forward Shift + Right Arrow 

Jump 2 min Backward Jump 2 minutes backward Shift + Left Arrow 

Jump 1/20th Forward Jump 1/20th of movie length forward Page Up 
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Jump 1/20th Backward Jump 1/20th of the movie length backward Page Down 

Jump to Movie End Jump to the movie end Home 

Jump to Movie Start Jump to the movie start End 

Select Next Marker Select the next marker Tab 

Select Previous Marker Select the previous marker Shift + Tab 

Select Slider Cursor Select the slider cursor Ctrl + Tab 

 

Control menu 

 

Menu item Description 

Frame Accuracy 

(Smart Mode) 
Enable the frame accurate trimming mode 

Obey samples times 
Use an alternative synchronization algorithm. By default, it is disabled. If the resulting file 

is out of sync after repeated trimming selecting this option should improve audio/vido 

synchronization. 

Ignore Trimming 

Errors 

Ignore trimming errors. 

 

Note: It is reccommended to keep it disabled by default.  

Slider K-Frame 

Positioning 

If this option is enabled, the cursor jumps to the nearest previous K Frame after you 

position the slider. This mode implements the What You See Is What You Get feature. 

If this option is disabled, you can navigate through all movie frames.  

Markers K-Frame 

Positioning 

If this option is enabled, the marker jumps to the nearest previous K Frame after you 

position it. This mode implements the What You See Is What You Get feature. 

If this option is disabled, you can set the marker at any movie frame. 

 

Note: If the start marker of a fragment is disabled, the fragment in the final movies will 

be started with the K Frame anyway. 

Note: If the end marker of a fragment is disabled, the fragment in the final movies will 

end with the frame at the marker position.  

Select streams... 
Opens the window for selecting video and audio streams for preview and trimming. For 

details, see Stream selection window  
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Tools menu 
 

 

 

Menu item Description 

Batch Manager Open the sumbenu of the Batch Manager item (available for Business Edition version only) 

Join Manager Open the Join Manager window  

Time Calculator Show the time calculator 

History List Open the history list of actions 

Index MPEG files in 
folder... 

Create index for MPEG files in the selected folder  

Index MPEG File Create index for the MPEG2 video file (*)  

Explore Folder Open Windows Exporer in the folder with the Input or Output media files 

Logging Open menu for actions with log files 

Show Preview filters Show the list of filters used for preview 

Preferences... Open preferences window 

Slicing... Open slicing window 

 
(*) - This operation is available for MPEG2 video only if the file has not been indexed yet.  
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Tools -> Batch Manager menu 
 

Note: This menu is available in Business Edition version only 

 

 
 

Menu item Description Shortcut key 

Show Batch Manager Show the Batch Manager window Ctrl + B 

Load Task List... Select a supported batch file  
 

Save Task List 
Save the Task List containin trimming task descriptions to an *.xtl file. 

See the Task List syntax in  Batch file format 
 

Save Task List As... 
Save the Task List containin trimming task descriptions to an *.xtl file to 

the specified folder. 

See the Task List syntax in  Batch file format  

Add Task To Batch Queue Add the current task to the batch queue A 

Update task Update the selected task in the batch queue  
 

Automatically set output 

file name 
If enabled allows to set the name for the output file automatically 

 

Start Batch Processing Start the batch processing 
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Tools -> Join Manager menu 
 

 

 

Menu item Description 

Load Join List Load a joining task from a file  

Save Join List Save the current joining task to a file  

Save Join List As... Save the current joining task to a file to the specified folder 

Show Join Manager Show the Join manager main window 

Join Manager Tooolbar Show/hide the Join manager toolbar window  

 

Help menu 

 

Menu item Description Shortcut key 

Help topics... Open the help file F1 

Keyboard ShortCuts Shows the Keyboard Shortcuts section in the help file 
 

Register... Register SolveigMM Video Splitter 
 

Ask for Support Open Solveig Mltimedia support section of the website 
 

Online Forum Open the Solveig Multimedia forum 
Open comparison table of SolveigMM products  
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Online HowTo Open HowTo section of the website 
 

Product Comparison Open the webpage with SolveigMM products comparison chat 
 

 
Check for updates 

Check if the latest Video Splitter version is installed 
 

About SolveigMM Video 

Splitter 
Open the About dialog box 

 
 

 

Stream selection window 

Stream selection window allows stream selecting for preview and editing. This window appears automatically after 
opening of file with multiple video or audio tracks. You can also open this window from Control -> Select 
streams... menu or from "Select streams..." button of the dialog window opens after selecting the trimming 
operation.  
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Stream selection window has the following view.  
 

 
 

To preview the desired video or audio stream in Video Splitter please click the icon with an eye ( ) near this 
stream.  
 

To save the stream in the resulted output video file please click the icon with scissors ( ) near this stream.  

Item of 
Window 

Description 
Shortcut 
key 

 

The stream is selected for preview - 

 

The stream is selected for editing. It will be saved in the output file. - 

 

The stream is not selected for preview - 

 

The stream is not selected for editing. It will not be saved in the output file. - 

 

 

Navigation controls 

 
Navigation controls are designed for navigation through an open source media file. Using these controls, you can 
start and stop playback, pause it or search for the necessary position forward and backward. Also, the current 
position and total duration are displayed.  
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Window item Description Shortcut key 

 
 

 

Previous K Frame  
 
Next K Frame 

Left arrow 
 
Right arrow 

 

Play/Pause  Space 

 

Pause  
 

 

 

Previous Frame  
 
 
Next Frame 

Cntr + Left 
arrow 
 
Cntr + Right 
arrow 

 

Slider cursor time position. You can edit this value manually  
 

 

Total file length 
 

 

 

Media panel 

Media panel allows adding the list of files of the same file format. Simply drag-and-drop file to the "Media" panel 

or click anywhere to open the dialog and add files. You could also click the ( ) button to open the new media 
file. 
 

We would like to draw your attention to the fact that the files should be of the same file format and video/audio 
parameters to be added to the media list. 
 
The files could be later dragged on the multi-timeline to be edited. 
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For your convenience there are two possible views of files in the list. By default is used "Extended view" ( ) 
as on the screenshot above.  
 

There is also possibility to set "Simple" view ( ) as shown below.  

 

 
 
If you have numerous files in the list, you can search appropriate by using special search string.  
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Splitting controls 
 
Splitting controls are the heart of Solveig Multimedia Video Splitter. Using these controls, you can manage the 
fragments that will or will not be saved in the final movie.  

You can set fragments to be cut or kept, invert or completely delete fragments from your movie. Finally, the main 
button that starts the splitting process is located on this panel. 
 

 

Window Item Description Shortcut key 

 

Add Marker: Add a new marker to the current slider 
cursor position. 

M 
 

 

 

Delete Marker:  Remove selected marker or 
markers. 

Delete 

 

Set audio silence: allows to set audio silence for the 
chosen fragment  

 

 

Save: Start trimming or batch processing (if there 

are any tasks in the batch queue) 
 
Browse output file 

Ctrl + T 

 

Left marker cursor time position. You can edit this 
value manually   

 

Right marker cursor time position. You can edit this 
value manually   

 

Zoom: Increase or Decrease  the slider timeline 
resolution to make editing neighbouring markers 
more comfortable  (*) 

NumPad +  
 
NumPad - 

 

Story board Off/On: turn on/off the story board  
 

 

Audio waveform On/Off: turn off/on the audio 
waveform  

 

Get screenshot: allows to make the screenshot of 
the chosen video frame 

 
Browse screenshot: allows to open folder with the 
created screenshot 
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Mute selected audio track. Muted track will not be 
present in either the preview or the output file. 

 

 Minimize selected track on the timeline.  

 
Displays zoom popup menu  

 
Invert intervals selection  

 

Sample fragments: 

Fragment color Description 

 

This fragment is set to be kept. It will be present in the final movie. 
The blue color of markers means you can edit it (delete, set it to be kept, etc.) 

A: 

 
B: 

  

A: Deployed state of the cut out fragment. This fragment is set to be deleted. It will not 
be present in the final movie 
The blue color of markers means you can edit it (delete, set it to be kept, etc.).  
 
B: Collapsed state of the cut out fragment. 
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This fragment is set to be kept. It will be present in the final movie. 
The white color of markers means that this fragment can not be edited. 

A:  

 
B: 

 

A: Deployed state of the cut out fragment. This fragment is set to be deleted. It will not 
be present in the final movie. 
The white color of markers means that this fragment can not be edited. 
 
B: Collapsed state of the cut out fragment. 

 
To place several files on the flexible timeline drag them to the right area of multitimeline after each file. View of 
Video Splitter with several files added on the multitimeline: 

 

Notice: You can also paste the file from the MEDIA list to any time positions of already added file on the 
multitimeline. 

Slider context menu 
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Menu item  Description  
Shortcut 
key  

Save Selected Fragment 
As...  

Specify the output filename and immediately save the selected fragment 
(start the trimming process)   

Save All Fragments As...  
Specify the output filename and immediately save all fragments (start the 
trimming process)   

Add Task To Batch 
Queue  

Allows to add Task to Batch Queue  
 

Add Marker  Add a new marker to the current slider cursor position  M  

Remove Marker(s)  Remove the current marker or fragment  Delete  

Keep Selected Fragment  Sets the type of the selected fragment to be kept  S 

Cut Out Selected 
Fragment  

Set the type of the selected fragment to be cut out  D  

Cut Out Previous 
Fragment  

Set the type of the previous fragment to be cut out  F  

Invert Time Line 
Fragments  

Invert time line fragments  I  

Set audio silence  Allows to mute sound of the selected fragment  
 

Clear All Markers  Remove all markers  Ctrl + C  

Delete Current Video  Allows to delete selected video or audio file from the multi-timeline  
 

 

Preview window 

 
The preview window is designed for easy navigation through media files and helps you put splitting markers as 
precisely as possible. 
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Progress window 

 

The progress window indicates the current progress in percentage terms. You can cancel splitting by clicking the 
Cancel button or hide Splitter to the system tray by clicking the Hide button. 
 

 
 
The Batch Processing progress window is shown below: 
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The upper progress bar shows the progress of the task being performed 
The lower progress bar shows the progress of all the tasks in the batch queue 
 
The Hide button hides Splitter to the system tray.  
When trimming is complete, the Splitter window appears. 
 
See also Splitter in system tray 

 
 

Splitter in system tray 

When you click the Hide button, Video Splitter is hiden to the system tray. 

 

The following context menu is available when Video Splitter is in the system tray: 

 

Menu item Description 

Show Program Restore Video Splitter from the system tray 

Show Progress Show the current progress 

Exit Program Cancel the trim process and exit 
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The following progress information will be shown if you click the Video Splitter system tray icon: 

One trimming task: 

 

Batch processing: 

 

 
Filters info window 
 
This window contains all the components necessary for Video Splitter to work properly. 

1. Click the icon of in the upper left corner of the window (You can use the Alt + Space shortcut)  
2. Click Info...      
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Batch manager window 

 

The Batch Manager available only in Video Splitter Business Edition. For more information see destinction between 

Home Edition and Business Edition. 

 

 
The Batch Manager window is used to edit the batch queue.  

Menu description:  

File menu  

 

 

Menu item Description Shortcut key 

Load Task List... Load a saved batch queue from a file (*)  - 

Save Task List Save the batch queue to a file - 

Save Task List As... Save the batch queue to a file to the specified folder - 

Open Task List in Notepad Open the batch queue in Notepad (*) - 

Hide Close this window - 

(*) - See Task List syntax in Batch file format 
 
Edit menu 

mk:@MSITStore:G:/portable/splitter/!%208%20мая%202020/SMMVSplitterBusinessPortable/Lang_Splitter/eng.chm::/SRC/Introduction.html#distinction
mk:@MSITStore:G:/portable/splitter/!%208%20мая%202020/SMMVSplitterBusinessPortable/Lang_Splitter/eng.chm::/SRC/Introduction.html#distinction
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Menu Item Description Shortcut key 

Add Task To Batch Queue Add the current Video Splitter task to the batch queue Ctrl + A 

Update task 
Update the task in the batch queue according to the changes made 
in Video Splitter 

U 

Edit Task with Video 
Splitter 

Edit the selected task in the Video Splitter main window Enter 

Delete Selected Task(s) Delete the selected task(s) Delete 

Delete Selected Fragment Delete the selected fragment(s) Delete 

Change Selected Task(s) 
Out Folder 

Change the output folder for all selected files. The program will not 
change the output filenames  

Disable audio on the 
selected task(s) 

Allows to disable audio content of the selected tasks Delete 

Disable video on the 
selected task(s) 

Allows to disable video content of the selected tasks 
 

Start Batch Processing Start batch processing Ctrl + T 

Start Batch Processing For 
Selected Task(s) 

Start batch processing for the selected tasks Shift + T 

Preferences Open preferences window Ctrl + T 

 
Log menu 
 

 

Menu Item Description 

Show log Show or hide the log window 

Write log 
file... 

Specify the filename all the messages will be written to during the batch manager operation. 
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Save log as... Save all log messages to a file 

Clear log Erase all messages 

 

Task queue field 

 

The list enumerates all tasks in the batch queue: 
 
Column description:  

Menu Item Description 

Task # Task number 

Source file Source filename 

Dest file Destination filename 

Fragments count Number of fragments to be cut 

Full time Total final file length 

Audio stream Audio stream number (*) 

Video stream Video stream number (*)  

Obey samples times 
Use an alternative synchronization algorithm. By default, it is disabled. 
If the final file is out of sync after repeated trimming, enabling this 
option should improve audio/video synchronization. (*) 

Accuracy Shows the selected editing accuracy.  

 
(*) - These fields can be edited in the batch manager window. Just click the cell with the left mouse button two 
times (not a double-click) or click the mouse wheel. You can select the necessary item from the drop-down list 
depicted below. 
 

 
Changing settings in the task list window 

 

Context menu description: 
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Menu item Description Shortcut key 

Save Task List As... Save the batch queue to a task list file. Ctrl + S 

Load Task List... 
Load a batch queue from  a task list file  

See Task List syntax in Batch file format  
Ctrl + O 

Start Batch Processing Start  batch processing Ctrl + T 

Start Batch Processing For 

Selected Task(s) 
Start  batch processing for selected task(s) Ctrl + T 

Delete Selected Task(s) Delete the selected task(s) Delete 

Edit Task with Video 

Splitter 
Edit the selected task in the main window Enter 

Select All Select all tasks 
 

Change Selected Task(s) 

Out Folder 
Change the output folder for all selected files. The program 

will not change the output filenames 
 

Disable audio on selected 

task(s) 
Allows to disable audio content of the selected tasks 

 

Disable video on selected 

task(s) 
Allows to disable video content of the selected tasks 

 

Fragment list 

 

mk:@MSITStore:C:/Program%20Files/Solveig%20Multimedia/SolveigMM%20Video%20Splitter%20Home%20Edition/Lang_Splitter/RUS.chm::/SRC/batchconsoleutil.html#batch-structure
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All the fragments to be cut out from the selected task are enumerated here. 
 
Fragment list context menu  
 

 

Menu item Description Shortcut key 

Delete Selected Fragment Delete the selected fragment Delete 

Show the Fragment in 
Video Splitter 

Show and select the fragment in the Video Splitter main window Enter 

 

 

Join manager window 

 

Join manager is used to join file with equal parameters like width/height of the frame, video/audio compression 
etc. Currently supported formats are listed here. The list enumerates all files to be joined together. Only the whole 

files can be joined for now. 

 
Columns description:  

Menu Item Description 

#  File order  

Source file  Source file name  

Full time  Full time of current file to be appended to resulting file 

Start time  Start time of the current fragment of the current file(*)  
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End time  End time of the current fragment of the current file(*)  

Audio  Audio encoding  

Samples/sec  Audio sampling frequency  

Mode  Audio mode 

Bitrate Audio bitrate 

Video Video compression 

Width Video frame width 

Height Video frame height 

Type the file type 

(*) - only full files can be joined so start time is the beginning of the file and end time is the duration of the file.  

Menu description:  

Menu "File"  

 

Menu item Description Shortcut key 

Add Media File(s) Add files into the list(*)  Ins 

Save Join List Save current joining task into the file 
 

Load Join List Load current task from the file 
 

Start Joining Start the joining progress for the current task 
 

(*) - if you try to add files with different parameters you will be prompted with the appropriate message in the 
satus bar of the "Join manager". 
 
Menu "Edit"  
 

 

Menu Item Description Shortcut key 

Move Up Move selected file up in the list Page Up 

Move Down Move selected file down in the list Page Down 

Delete Selected Items Delete all selected items from the list Del 
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Clear List Delete all items from the list 
 

 
 
Context menu:  

 

The context menu commands duplicate menu commands for convenience, and it's "Add" and "Move" commands 
are applied to chosen file in the list ( the highlighted one ). Others are applied to the list in general. 

 
Join manager toolbar 
 

 
 
The toolbar also duplicate some commands that allow you to perform joining not opening the main Join Manager 
window. 

Toolbar Item(left to right) Description 

Start Joining Starts current joining task 

Show / Hide Shows / Hides the Join manager main window 

Add File(s) Adds files into the list 

Load List Loads joining task from file 

 

 
 

Slicing window 

Slicing window allows to fulfill splitting of the file into parts. Fragements length can be specified by duration, by 
size or by number of equal parts.  
 
To open the slicing window follow to Tools -> Slicing.. or Edit -> Slicing.. menu and open one or several files 
you would like to slice. 
 
The slicing window is depicted on the screenshot below: 
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To start slicing, select the type of spliting: by duration, by size, into equal parts. Enter the value for the selected 
type of slicing. You can change the order of the files prepared for slicing using appropriate buttons with arrow 
icons. 
 
This window also displays the duration and the size of the file or current project.  
 
Click "Start" to begin the slicing. 
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Preferences window 

"Hot Keys Settings" tab 
 

 
 
Video Splitter allows to choose the defined settings of your desired hot key profile.  

Simply enter your hot key for the chosen operation (right column), click Yes in the appeared information window 
and then enter the desired name for the new profile, then click on the OK button. The new profile will appear in 
the Current Profile combobox.  

 

You can remove your profile by selecting the needed one in the "Current profile" combobox and clicking on the 
Remove button.  
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"Smart Mode settings" tab 

 

 
 
Smart Mode Settings window allows to choose the decoder and encoder that will be used in re-encoding process 
of first and last GOP when frame accuracy trimming (Smart Mode) is enabled.  
To select the desired codeñ, choose one or several from the Encoder/decoders list and press the Force 
selected button.  
The chosen codec will appear in the Preferred codecs list.  
You can choose several codecs from the Encoder/Decoder list. All they will be placed to preferred codec 
"Preferred codecs" area.  
 
Important notice: the decoder or encoder can be forced only for WMV and AVI. 
 
Video Splitter uses codec that will be suitable for the format of the opened file.  
You can use Move Up and Move Down buttons, to change the priority of the chosen codec. 
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"Playback Settings" tab 

 

This tab allows to select video renderer.  
If the default video renderer is not worked, then it is possible to select another video renderer.  
EVR video renderer is recommended for users of Windows 7 if fps of video is more then 30.  
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"Audio Waveform" tab 

 

 

 
"Waveforms files path" setting defines waveform data cache path, that is used by Video Splitter. 
 
"Follow the slider while the waveform is constructed" defines the way of waveform building. When the 
option is enabled the waveform will be built from the selected by the user slider position. Tick this checkbox if you 
would like the waveform building follow the slider movements.  
 
If you would like you can change the file path for this file to keep free space on the system drive. 
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"Output Files Settings" tab 

 

 
Output files settings tab allows to set mask of the output file and select output folder settings. The files mask is 
intended to generate the names of the output files, using build-in macroses. 
The mask is the template that consist of macros. It is possible to add predefined macros using special buttons 
under the "Mask of output file names" line to current cursor position at template edit box.    

Output file mask format: 

[source] uses the name of the source file for the target. 

[n] macros automatically numbers the (one or more) target. Target will automatically be numbered, if parameter 
is set, even if source name is not used. 

[n:4] macros is the current number of fragment with defined minimum number of characters printed. Zeros are 
added to the left of the values. 

[time] macros is intended for defining the current date time of the output file name. 

[n:resetnextday] output number will be incremented during a day and reset nte next day. 

[time] output current date and time in the following structure: YYYY_MM_DD_hh_mm_ss. 

[time:YYYMMDD] output current date and time in the user-defined structure. in this example - YYYYMMDD. 
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[computerid] outputs the idendificator of the working PC. It can be set in the Computer ID field. 

To add the required macros just click on the button with the macros name and then change it in the Mask of the 
output files names field if needed. 

You can change the order of this macroses to get the files with names that will be suitable for you. 

To reset the mask to initial view, just click on the Reset to defaults button. 

Below please find examples of mask templates and the output files names. 

For example we have the Video.avi input file and would like to save three fragments from the file. We make this 
operation on September 25, 2012 at 18:50:30. 

The mask template The output file name 

[n] 
1.avi 
2.avi 
3.avi 

[source]_[n] 
Video_1.avi 
Video_2.avi 
Video_3.avi 

[source]_[n:2] 

Video_01.avi 
Video_02.avi 
Video_03.avi 

 

[source]_[n]_[time] 
Video_1_2012_09_25_18_50_30.avi 
Video_2_2012_09_25_18_50_30.avi 
Video_3_2012_09_25_18_50_30.avi  

 
Output folder settings allows to define the output folder.  
It is possible to save to the same folder of the input file, save to the last output folder or save to the specified 
folder.  

 

mk:@MSITStore:C:/Program%20Files/Solveig%20Multimedia/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter%203%20chm(eng)/SolveigMM%20Video%20Splitter%203%20chm(eng)/SRC/usage.html::/
mk:@MSITStore:C:/Program%20Files/Solveig%20Multimedia/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter%203%20chm(eng)/SolveigMM%20Video%20Splitter%203%20chm(eng)/SRC/usage.html::/
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“View” tab  

 

 

Setting Description 

Show input/output 
information panel 

Allows to show or close input/output information panel 

Show GPS navigation 
panel  

Allows to show or close GPS navigation panel 

Show GPS navigation 
sensors panel  

Allows to show or close GPS navigation sensors panel 

Show splash screen  Allows to show or close splash screen on the product start 

Show info item in 
system menu  

Allows to show info item in system menu 

Show logo on video 
window background  

Allows to show or hide logo on video window background 

Show extra view video 
window on dvr files 

Allows to show extra view video window of rear camera on dvr files 

Enable compare video 
mode 

Allows to show compare video mode 

 
It is possible to set in this tab the text color for message boxes and text for input/output information panel. 
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"Control" tab  

 

 

 

 

Setting  Description  

Don't save "Recent 
files"  

Allows to disable saving of recent files in Recent files history 

Keep project settings 
(intervals, selected 
streams) for all files 
within a session 

Allows to save project settings (intervals, selected streams) for all files within a session 

Show warning when 
applying project 
settings 

Allows to enable or disable showing of warning message when applying project settings  

Automatically save 
project backups 

Allows to automatically save project backups 

Show message after 
saving screenshot 

Allows to show the message after saving of screenshot  

Don't duplicate 
markers at the same 

Disallows duplicating markers at the same position  
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position  

Close application after 
trimming 

Allows to close automatically the application after trimming  

Ask for output file 
name if "Trim" pushed  

If chosen, the application asks destination file name on trimming  

Navigate to interlaced 
fields on AVC video 

Allows to navigate to interlaced fields on AVC video 

Disable frame 
alignment  

Allows to disable frame alignment. This feature is required for the accurate editing of 
audio. With this feature the selected position on the timeline is aligned accurately 
according the selected time position. Otherwise the selected position is aligned according 
the time position of the frame beginning that leads to changing from constant frame rate 
to variable for video as a side effect.  

Padding on MPEG TS 
files  

Allows to make padding on MPEG TS files  

Keep MPEG TS PIDs  Keeps elementary transport stream PIDs in transport stream format  

Saving MPEG2 closed 
captions data on re-
encoded frames  

Allows saving closed captions data in VES stream on re-encoded frames  

Enable single thread 
mode for MPEG2 
encoder  

Option enables this mode in Elecard encoder. If it is disabled it generates at different runs 
on the same raw data different encoded stream)  

Index MPEG audio files  Allows to index MPEG audio files  

Index MPEG video files  Allows to index MPEG video files  

RTP hint tracks on MP4 
files  

Option is used for the preservation of RTP hint track information used by the streaming 
server (eg Darwing) in the broadcasting. Without this data for example Darwing 
streaming server will not work with the output file.  

 
It is possible to set in this tab the text color for message boxes and text for input/output information panel. 
 
 

 

"Subtitles" tab 

The "Subtitles" tab allow to make settings for placement and font of subtitles for output files.  

It is possible to select new position of subtitles in the resulted file by clicking the "Override subtitles placement" 
and by entering new values of X, Y positions.  

To change the subtitles font, please select "Override subtitles font" and click the "Choose font" button.  
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"GIF Export Settings" tab 

"GIF Export Settings" tab allow to make special settings for GIFs that Video Splitter could create. 
You could set frames count control:  

  Save equidistant frames:  

- Frames count 
- Frame duration (1/100s) 

 Overide fps - set frames per second value  
 Keep original fps 
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Using Solveig Multimedia Video Splitter 

In this section:  

 Opening a source file  
 Using the splitting controls  
 Saving a media file  
 Starting the trimming process  
 Working with the batch queue  
 Working with MPEG-2 files  

 

Opening a source file  

Operations with files are performed via the menu bar in Solveig Multimedia Video Splitter. 

To open a source file, go to the menu bar, select File -> Open Media File... Select your video file in standard 
Open File dialog box. This file will not be changed, deleted or moved during the splitting process. 
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To set the destination file, select File -> Output File... and specify the name for the destination file. If a file with 
the same name already exists, you will be asked if you want to replace the old file with the new one. You can 
overwrite the old file or specify a new filename for the destination file. 

If the file you edit contains several audio and/or video streams then after the file opening you will see Stream 
selection window, where you can select video and audio tracks for preview and editing.  

See also: File menu, Stream selection window. 

 

Using the splitting controls  

Before you start the trimming process, you should define the fragments you want to be cut or kept in the output 
file. 

To add a new fragment to the slider: 

1. Navigate to the beginning of the future interval 

2. Press the Set New Marker key (M) or select the Edit -> Set New Marker menu item from the menu bar 
3. Navigate to the end of the future interval 
4. Repeat step 2 
5. If necessary, mark the interval as "Cut Off" by selecting Edit -> Cut Off Selected Fragment (D) or pushing 

the "Scissors" ( ) button 
6. If you need to change the start or stop interval positions, just double click on the collapsed marker and drag the 
markers to their new positions 

 

Sample intervals: 

Fragment color Description 

 

This fragment is set to be kept. It will be present in the final movie. 
The blue color of markers means you can edit it (delete, set it to be kept, etc.) 

A: A: Deployed state of the cut out fragment. This fragment is set to be deleted. It will not 
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B: 

  

be present in the final movie 
The blue color of markers means you can edit it (delete, set it to be kept, etc.).  
 
B: Collapsed state of the cut out fragment. 

 

This fragment is set to be kept. It will be present in the final movie. 
The white color of markers means that this fragment can not be edited. 

A:  

 
B: 

A: Deployed state of the cut out fragment. This fragment is set to be deleted. It will not 
be present in the final movie. 
The white color of markers means that this fragment can not be edited. 
 
B: Collapsed state of the cut out fragment. 
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Splitting controls 

Window Item Description Shortcut key 

 
 

Add New Marker:   Add a new marker to the current 
slider cursor position. 

 

M 
 

 

 

Delete Marker:  Remove selected marker or 
markers. 

Delete 

 

Set audio silence: allows to set audio silence for the 

chosen fragment  

 

 

Save: Start trimming or batch processing (if there 
are any tasks in the batch queue) 
 
Browse output file 

Ctrl + T 

 

Left marker cursor time position. You can edit this 

value manually   

 

Right marker cursor time position. You can edit this 
value manually   

 

Zoom: Increase or Decrease  the slider timeline 
resolution to make editing neighbouring markers 
more comfortable  (*) 

NumPad +  
 
NumPad - 

 

Story board Off/On: turn on/off the story board  
 

 

Audio waveform On/Off: turn off/on the audio 
waveform  

 

Get screenshot: allows to make the screenshot of 
the chosen video frame 
 
Browse screenshot: allows to open folder with the 
created screenshot 

 

 
Mute selected audio track. Muted track will not be 
present in either the preview or the output file. 

 

 Minimize selected track on the timeline.  
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Displays zoom popup menu  

 
Invert intervals selection  

 

Slider context menu 

 

 

 

 

Menu item  Description  
Shortcut 
key  

Save Selected Fragment As...  
Specify the output filename and immediately save the selected 
fragment (start the trimming process)   

Save All Fragments As...  
Specify the output filename and immediately save all fragments 
(start the trimming process)   

Add Task To Batch Queue  Allows to add Task to Batch Queue  
 

Add New Marker  Add a new marker to the current slider cursor position  M  

Remove Marker(s)  Remove the current marker or fragment  Delete  

Keep Selected Fragment  Sets the type of the selected fragment to be kept  S 

Cut Out Selected Fragment  Set the type of the selected fragment to be cut  D  

Cut Out Previous Fragment  Set the type of the previous fragment to be cut  F  

Invert Time Line Fragments  Invert time line fragments  I  

Set audio silence  Allows to mute sound of the selected fragment  
 

Clear All Markers  Remove all markers  Ctrl + C  

Delete Current Video   Allows deleting the current video file from the multitimeline  
 

 

 
 

Starting the trimming process  

To start the trimming process after you set all the fragment you want to be deleted/saved, select File -> Save 
Media File As... (for details, see File menu) or click the Save Media File As.. quick button (for details, click the 
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Trim button (for details, see Splitting controls)  
 
Note: You can save (trim) any selected fragment using the Save Selected Fragment As.. item from the slider 
context menu (for details, see Splitting controls)  

 

Working with the batch queue  

To create a new batch queue (task list):  

1. Open the media file you want to edit, set all the fragments you want to be saved/removed. For details, see 
Opening source file and Solveig Multimedia Video Splitter interface  

2. Add the task to the queue. To do it, select Tools -> Batch Manager -> Add Task To Batch Queue 

3. Repeat steps 1 and 2 for all the files you want to process. 

See also Tools menu, Keyboard shortcuts 

 

Also, you can add a task to the queue by selecting File -> Save Media File As... from the menu, or clicking the 

Information panel quick button, or selecting the Save selected fragment as.. item from the slider context menu 

(for details, see Splitting controls). You should select the Use mask for output files names checkbox as shown 

below: 

mk:@MSITStore:G:/portable/splitter/!!!%2023%20сентября%20хоум%20версия%20последняя/SMMVSplitterHomePortable/Lang_Splitter/eng.chm::/SRC/interface.html#slider


 
SolveigMM Video Splitter 

  
 

 
Solveig Multimedia  

 
56 

 

To open the Batch Manager window, select Tools -> Batch Manager -> Show Batch Manager on the menu or 

select Tools -> Batch Manager -> Load Task List... to open a task list file.  

The Batch Manager window allows you to change audio/video streams, the Obey samples times attribute, 

delete any fragments, etc. For details, see Tasks queue field.  

To edit a task, you have to open it in Video Splitter, change its fragments or settings and update it: 

1. Select the task you need to edit. Select the Edit -> Edit Task with Video Splitter menu item or the Edit 

Task with Video Splitter item from the context menu or press the Enter hot key. For details, see Tasks queue 

field, Keyboard shortcuts  

 

2. Edit the task in the Video Splitter main window. To view the existing fragments in Video Splitter, you can use 

the Fragment list field. To do it, select Show the Fragment in Video Splitter from the context menu or press 

the Enter hot key. For details, see Keyboard shortcuts  

 

3. After you edit the trimming settings in Video Splitter, update the task in the batch queue by selecting the Tools 

-> Batch Manager -> Update Task menu item or the Edit -> Update Task item in the Batch Manager 

window. 
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Working with MPEG-2 files 

This section describes how to use SolveigMM Video Splitter with MPEG-2 video.  
 
Open the MPEG-2 video file you want to split: 
Select File -> Open Media File... from the menu.  

 

The standard Windows Open File dialog box will appear.  
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Select the video file and click Open.  
 
Note. Indexing the MPEG file is recommended but not required.  

With no index, you will not be able to use K-Frames and the trimming process can be inaccurate. You could 
enable/disabple option in the Preferences -> Control tab to "Index MPEG audio" or "Index MPEG video files". 

If you cancel the indexing process or choose not to index the file, you can index it later in the following way: 
select Tools -> Index MPEG file in the folder or  Tools -> Index MPEG files from Media list from the 
menu.  

If MPEG2 file contains several video or audio tracks then the Stream selection window will be opened.  
 
It contains two tabs: Programs and Tracks, where you can select the desired stream by clicking the icon near 

the appropriate stream. 
 

The icon with an eye ( ) shows what stream is selected for preview.  

The icon with the scissors ( ) shows what stream is selected for editing.  
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Item of 

Window 
Description 

Shortcut 

key 

 

The stream is selected for preview - 

 

The stream is not selected for preview. It will be not shown. - 

 

The stream is not selected for editing - 

 

The stream is not selected for editing. It will not be saved in the output file. - 

What to do next is described in How-to section.  

 

How to... 

 register Solveig Multimedia Video Splitter  
 open a video file  
 select video and audio streams  
 preview a video clip  
 navigate in your video  
 set and delete markers  
 set fragments to be kept or cut  
 fix audio/video synchronization  
 start splitting  
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 start joining  

 

How to register Solveig Multimedia Video Splitter 

 

You can license this program right from our web page at http://www.solveigmm.com/en/products/video-splitter/. 

Click the Buy Now link there. We offer many different ways to order it, including secure web forms, phone, fax 

and mail orders, as well as corporate purchase orders. However, since the order information is likely to change in 

the future and your downloaded copy of Video Splitter may be several months or even years old, you should 

access our webpage for the most current order information. 

 

To find the current prices, please visit us on the web at http://www.solveigmm.com/. 

 

After ordering you will get an activation key of the following format: "XXXXX-XXXXX-XXXXX-XXXXX".  

Online Activation 

To activate your product online please do the following:  

1. Open Video Splitter and click "Help->Register" menu item. 

 

2. Enter your Activation key and click "Activate" button. This method requires a connection to the Internet. 

http://www.solveigmm.com/en/products/video-splitter/
http://www.solveigmm.com/
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      3. Fill the license information fields and click "Activate" button again. 

 

Offline Activation 

If for some reason you can't activate Video Splitter online there is an option of the offline activation (available only 

in Business version of the product) that doesn't require the Internet connection on the computer where Video 

Splitter is installed 

 

To activate the product offline please do the following:  

1. Open Video Splitter and click "Help->Register" menu item. 



 
SolveigMM Video Splitter 

  
 

 
Solveig Multimedia  

 
62 

 

2. Click "or use offline activation" link. 
 

 

3. Enter your activation code and click "Get activation string" button. 
"videosplitter_offline_activation.txt" should appear with instructions on how to get a serial number to 
complete the activation process. 
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4. Open the URL http://solveigmm.com/wlm/offline.php in your web-browser and paste the activation string 
then click "Submit" button. As a result you will get a Serial Number. To complete the activation please 
copy the serial number from a web-browser and paste it into the appropriate field of the Video Splitter 
licensing dialog. Then click "Activate" button again. 
 

 

 

 

How to open a video file 

 

To open the video file you want to split, do the following: 
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1. Select File -> Open Media File... from the menu. The standard Windows Open File dialog will appear.  
2. Find your video file and click Open. 

 

 

 

See also Supported file formats, File menu

 

How to select video and audio streams 

 

Solveig Multimedia Video Splitter allows you to choose the audio and video streams that will be rendered into the 

final movie. To choose the streams, open the Control menu and follow "Select streams..." menu item.  

 

 

The special window will be opened. It is possible to select audio and video streams for the preview and editing 

here.  

You can see this window also after opening of any file with multiple video or audio streams.  
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Choose the stream for preview by clicking the icon with an eye ( ). To select streams you want to be present 

in the output file click the icon with scissors ( ).  

 

In the example on the above screenshot the one video stream and two audio streams were selected for editing.  

 

You can also open the stream selection window by clicking the "Select streams..." button from the dialog 

window that opens after the trimming start. 
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See also Control menu, Stream selection window 

 

How to preview a video clip 

1. Open a video file  
2. To start playback, click the Play button. Also, you can use the Edit->Play menu item or the Space 

shortcut key.  
3. To pause playback, click the Pause button. You can use the Edit -> Pause menu item or the Space 

shortcut key.  

Window element Description Shortcut key 

 

Previous K Frame Left arrow 

 

Next K Frame Right arrow 

 
Play/Pause Space 
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Next Frame Ctrl + Right arrow 

 

Previous Frame Ctrl + Left arrow 

 

See also Navigation controls, Edit menu, Keyboard shortcuts 

 

How to navigate in your video 

1. To advance to the next K frame, click the Next K Frame button or select the Edit->Next K Frame 
menu item from the menu. You can also use the Right arrow shortcut key.  

2. To jump to the previous K frame, click the Previous K Frame button or select the Edit->Previous K 
Frame menu item. The Left arrow shortcut key is also available.  

3. Left-click the timeline at the position you need.  
4. Type the necessary time in the edit box in the Navigation controls in the HH:MM:SS.mS format. The 

position will be automatically adjusted to the nearest previous K frame.   

Window element Description Shortcut key 

 

Previous K Frame Left arrow 

 

Next K Frame Right arrow 

 

Previous Frame Ctrl + Left arrow 

 

Next Frame Ctrl + Right arrow 

 

See also Navigation controls, Edit menu, Control menu, Keyboard shortcuts 

 

How to set and delete markers 

To select fragment you need to do the following:  

1. Navigate to the position where you want to add it.  
2. Press the Set new marker key (M) or select the Edit -> Set New Marker menu item  

To delete a marker:  

1. Left-click the marker you want to delete.  
2. Press Remove marker/fragment key (Delete) or select the Edit -> Remove marker or markers 

menu item.  

To delete all markers from the timeline, select the Edit -> Clear All Marks menu item or use the Ctrl + C 

shortcut 

Note: markers will be deleted without any confirmation 
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Window element Description Shortcut key 

 

Add Marker M 

 

Delete Selected Marker Delete 

 
Clear All Markers Ctrl + C 

 

See also Edit menu, Keyboard shortcuts, Splitting controls 

 

How to set fragments to be kept or cut 

To define a new fragment:  

1. Navigate to the beginning of the future fragment.  
2. Press the Add a marker key (M) or select the Edit -> Set New Marker menu item.  
3. Navigate to the end of the future fragment.  

4. Repeat step 2.  

To adjust the time of the fragment start and stop:  

1. Deploy the collapsed interval. Select the marker at the beginning/end of the fragment.  
2. Drag the marker to the necessry position (or use the the Next K Frame / Previous K Frame buttons) 

or timebox of the appropriate marker.  

To delete a fragment:  

1. Left-click the fragment you want to delete.  
2. Press the Remove marker(s) key (Delete), or select the Edit -> Remove marker or markers menu 

item.  

Note: the fragment will be deleted without any confirmation. 
 
To set a fragment to be kept:  

1. Left-click the fragment you want to keep.  
2. Right mous click and select "Keep On Selected Fragment key (S)" in the opened context menu or 

select the Edit -> Keep On Selected Fragment menu item. 

To set a fragment to be cut: 

1. Left-click the fragment you want to delete.  
2. Press the Cut Off Selected Fragment key (D) or select the Edit -> Cut Off Selected Fragment menu 

item.  

Window element Description Shortcut key 

 

Add New Marker: Add a new marker to the current slider cursor position. M 

 

Remove Selected Markers: Removes selected markers from the timeline. Delete 

 

See also Edit menu, Keyboard shortcuts, Splitting contros 
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How to fix audio/video synchronization 

 

Solveig Multimedia Video Splitter is designed to split media files without loosing audio/video synchronization. 
However, some media files lose synchronization after splitting. To avoid losing sync, you can try to do the 
following: 

1. Open your video file. 
2. Define the fragments you want to keep in the final movie.  
3. Select the Control -> Obey Sample times menu item.  

4. Continue the splitting process as usual.  
 

See also Control menu, How to set fragments to be kept or cut 

 
 

How to start joining  

 

To start the joining process:  

1. Add the video (audio) files you want to join either using drag'n'drop or by clicking the Add Media File(s) 

button. 

 

 
 

2. If the files have different parameters, you will be notified. 
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3. Sort files. 

 

4. Start joining by clicking the Start Joining button or selecting the File->Start Joining menu item. 

 

 

5. Enter the name of the destination file and click Save. The progress bar will appear and show the progress.  

 

 

How to start splitting  

 

To start the trimming process:  

 
1. Open your video file. 
2. Define the fragments you want to keep in the final movie  
3. Press the Trim key (Ctrl + T) or select Edit -> Start Trimming 
4. If you are asked for a file name, enter a name for the destination file and click Save.  
You can also select streams you would like to be edited and saved in the output file by clicking the "Select 
streams..." button. The progress bar will appear and showing that splitting is in progress.  
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Note: selecting the File -> Save Media File As... menu item also starts the trimming process. 

 

Window element Description Shortcut key 

 

Save: Start the trimming process Ctrl + T 

 

See also Edit menu, Keyboard shortcuts, Splitting controls, Batch manager 

 

SolveigMM Batch Splitter console utility 

The SolveigMM Batch Splitter console utility (SMM_BatchSplit.exe) duplicates the SolveigMM Video Splitter 
video/audio trimming functionality in the console mode. It allows you to trim AVI, ASF/WMV/WMA, MPEG-1, 
MPEG-2, MP4, MOV, MKV, AVCHD, MPEG Audio files (See Supported File Formats for more details). The files and 
parameters should be described in the batch file (*.xtl) specified as the input parameter to the utility.  
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XTL batch file could be obtained by "Save Task List As..." command from Video Splitter's main 
window  or  SolveigMM Video Splitter Batch Manager "File" menu.  See Batch file structure  and XTL batch file 
samples for more details.  

Usage:  
         BatchSplit.exe [-L logfilename] [-LD log_dir] [-P profile] file.xtl  

Parameters:  
         -L logfilename: Log filename. By default it equals to "BatchSplit.log". Use the NULL value to disable 
logging. 

         -LD log_dir: Log files directory. Create log files from components involved in operation. 

         -P profile: Set codecs profile. 

          file.xtl: XTL Batch file path name.  

Example:  
         BatchSplit.exe -L MySplitTaskLog.log "D:\Video\SplitTasks\MySplitTask.xtl"  

Note: SolveigMM Batch Splitter console utility available only in SolveigMM Video Splitter Business Edition. 

For more information see destinctions between Home Edition and Business Edition.

 

Batch file structure  

Video Splitter batch files have the *.xtl, *.jxtl extensions and are based on the DirectShow Editing Services XTL 

format.  

 

Note: All the sections and attributes are case-sensitive and must be in the lower case. The values must be 

enclosed in quotation marks ("").  

 
timelines Element 

 

The timelines element is the root XML node.  

 

Example: 

<timelines version="2"> 

</timelines> 

 

Attributes:  

Attribute name  Possible values  Required  Description  

version  2  Yes  The name attribute specifies the output filename with its path  

 

Parent/Child Information:  

Parent  Children  

none  timeline  
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timeline Element  

 

The timeline element describes particular timeline.  

 

Example:  

<timeline>  

</timeline>  

 

Attributes:  

no attributes specified.  

 

Parent/Child Information:  

Parent  Children  

timelines  group  

 

 

group Element  

 

The group element defines output files parameters.  

 

Example:  

<group name="..." mode="...">  

</group>  

 

Attributes:  

Attribute name  Possible values  Required  Description  

output  string with file path name  No  Specifies the output file name with it's path  

out_type  see Output file types No  
Specifies output file type.   

Note: This parameter should be set depending on 
input format and video audio codec. 

outdir  string with file path  No  
Specifies the output files' path for tasks with multiple 

files output  

outmask  see Output file mask format  No  
Specifies the output files' mask for task with multiple 

files  

compatibility  see Compatibility types  No  Specifies the output files compatibility  

 

 

Output file types: 
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avi - Audio Video Interleave 

asf,wmv - Window Media Video 

wma - Windows Media Audio 

mpa, mp3, mp1 - MPEG audio 

mpg_ts - MPEG2 transport stram 

mpg_ps - MPEG2 program stream 

mpg_ves -  MPEG2 video elementary stream 

mpg1_sys - MPEG1 system stream 

mpg1_ves - MPEG1 video elementary stream 

avc_ves - AVC video elementary stream 

wav - Waveform Audio 

matroska - Matroska 

mp4 - MPEG-4 Part 14 file format 

flv - Flash Video 

gif - Animated GIF 

yuv- I420 YUV  

raw - Raw format 

 

Compatibility types: 

 

 original - Ordinary file 

 GeoVision - GeoVision RemoteView compatible file 

 BlueSonicF008 - DVR BlueSonic F008 file 

 

Parent/Child Information  

Parent Children 

timeline track 

 

 

task Element  

 

The task element defines operation that is applied to timeline.  

 

Example:  

<task type="..." time="..." timeFormat="..."/>  

 

Attributes:  

Attribute 

name  
Possible values  Required  Description  

type  
joining, indexation, 

autosplit  
No  Specifies the task type. See Task types for detais  

time  time string  No  Specifies the time parameter for task  

timeFormat  
100ns_units, time10ms, 

parts, bytes  
No  

Specifies how to interpret value specified in time 

attribute. See time format types  
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Task types: 

 

joining - Join should be applied to timeline 

indexation - Indexation operation should be applied to clip 

autosplit - Slicing by time, by size, into parts should be applied to timeline 

 

 

Parent/Child Information:  

Parent  Children  

group  none  

 

track Element  

 

The track element is container for clip elements it defines common attributes for clips if it is not set.  

 

Example:  

<track video="..." audio="..." text="..." obey_sample_times="..." accuracy="..." 

compatibility="...">  

</track>  

 

Attributes:  

Attribute name  Possible values  Required  Description  

video  any number  No  
Specifies the number of video stream. The 0 value means no 

video stream. The -1 value means - all video streams  

audio  any number  No  
Specifies the number of audio stream. The 0 value means no 

audio stream. The -1 value means - all audio streams  

text  any number  No  
Specifies the number of text stream. The 0 value means no 

audio stream. The -1 value means - all text streams  

obey_sample_time  0, 1  No  

The obey_sample_times attribute specifies whether an 

alternative synchronization algorithm should be used:  

 

0 = Do not use obey_sample_time 

1 = Use obey_sample_time 

 

By default, obey_sample_time equals to 0  

accuracy  
see Trimm 

accuracy types  
No  Specifies accuracy type in trimming operaion  

compatibility  
see Compatibility 

types  
No  Specifies graph compatibility option for operation  

flags 
see Trimm flags 

No 
Specifies  coma separated options used in trimming 
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for details operation.  See Trimm flags for details 

 

Trimm accuracy types: 

 

frame - Frame accuracy 

gop - K-frame (GOP) accuracy 

 

Parent/Child Information:  

Parent  Children  

group  clip  

 

clip Element  

 

The clip specifies the media source.  

 

Example:  

<clip src="..." index="..." video="..." audio="..." text="..." start="..." stop="..." timeFormat="..." 

flags="..."/>  

 

Attributes:  

Attribute 

name  
Possible values  Required  Description  

src  
string with file path 

name  
Yes  Specifies the path name of the input media file  

index  
string with index file 

path name  
No  Specifies the path name of the input media file' index  

video  any number  No  
Specifies the number of video stream. The 0 value means no 

video stream. The -1 value means - all video streams  

audio  any number  No  
Specifies the number of audio stream. The 0 value means no 

audio stream. The -1 value means - all audio streams  

text  any number  No  
Specifies the number of text stream. The 0 value means no 

audio stream. The -1 value means - all text streams  

start  time string  No  
The start time of the fragment. See time format types for 

details  

stop  time string  No  
The stop time of the fragment. See time format types for 

details  

timeFormat  
100ns_units, 

No  
Specifies time format for start, stop attributes. See time 
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time10ms, position  format types for details  

flags  audio_silence  No  
Specifies options used in trimming operation. See Trimm flags 

for details  

 

Time format types: 

 

100ns_units - Value is interpreted as 100ns Units ( 1 sec = 1e7 UNITS) 

time10ms - Value is set in format "HH:MM:SS.mS" 

position - Value is set using key words: "begin", "end" 

bytes - Value is interpreted as bytes count 

parts - Value is interpreted as parts count 

 

Trimm flags: 

 

audio_silence - audio will be muted on fragment 

 

Parent/Child Information:  

Parent  Children  

track  no  

 
XTL batch file samples 

 

Trimming  

<timelines version="2" > 

  <timeline> 

    <group output="C:\Base\output\2a2v_0001.avi" > 

      <track video="1" audio="2" accuracy="frame" > 

        <clip src="C:\Base\avi\2a2v.avi" start="00:00:00.00" stop="00:12:32.00" /> 

        <clip src="C:\Base\avi\2a2v.avi" start="00:32:41.00" stop="00:42:02.00" /> 

        <clip src="C:\Base\avi\2a2v.avi" start="00:54:09.00" stop="01:08:51.00" /> 

      </track> 

    </group> 

   </timeline> 

   <timeline> 

     <group output="C:\Base\output\2a2v_0002.avi" > 

        <track video="1" audio="1" accuracy="frame" > 

          <clip src="C:\Base\avi\2a2v.avi" start="00:00:00.00" stop="00:12:32.00" /> 

          <clip src="C:\Base\avi\2a2v.avi" start="00:32:41.00" stop="00:42:02.00" 

flags="audio_silence" /> 

          <clip src="C:\Base\avi\2a2v.avi" start="00:54:09.00" stop="01:08:51.00" />  

        </track> 

     </group> 

    </timeline> 

    <timeline> 

     <group output="C:\Base\output\H263_PCM_0001.avi" > 

        <track video="1" audio="0" accuracy="gop" > 

          <clip src="C:\Base\avi\H263_PCM.avi" start="00:11:48.08" 

mk:@MSITStore:C:/Users/olga/Desktop/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter%205%20chm(eng)/SMMVSplitter.chm::/SRC/batchconsoleutil.html#Time_format_types
mk:@MSITStore:C:/Users/olga/Desktop/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter%205%20chm(eng)/SMMVSplitter.chm::/SRC/batchconsoleutil.html#Trimm_flags
mk:@MSITStore:C:/Users/olga/Desktop/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter%205%20chm(eng)/SMMVSplitter.chm::/SRC/batchconsoleutil.html#xtlformat_track
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stop="00:20:14.52"/> 

        </track> 

     </group> 

    </timeline> 

</timelines> 

 
3 files will be created as a result:  
 

1) C:\video\result\2a2v_0001.avi - the file will consist of three sequential fragments from 
C:\video\2a2v.avi  

Start Time  End Time  

00:00:00.00  00:12:32.00  

00:32:41.00  00:42:02.00  

00:54:09.00  01:08:51.00  

 
The file will contain the video stream and the second of two audio stream. 
 

2) C:\video\result\2a2v_0002.avi - the file will consist of three sequential fragments from C:\video\2a2v.avi as for 
the first timeline but in second fragment audio will be muted.  
3) C:\video\result\H263_PCM_0001.avi - the file will consist of one fragment from C:\video\H263_PCM.avi  

 

Start Time  End Time  

00:11:48.08  00:20:14.52  

 

The file will contain only the video stream. 

The file will contain only the audio stream.  

 

Indexation  

<timelines version="2"> 

  <timeline> 

    <group output="C:\video\a.mpg.mlmix" > 

      <task type="indexation"/> 

        <track> 

          <clip src="C:\video\a.mpg" />  

        </track> 

     </group>  

    </timeline> 

</timelines> 

As a result, the index file would be created for the corresponding MPEG-2 file specified in the clip  

 

Joining  

<timelines version="2" > 

  <timeline> 

    <group output="C:\Test_full.mp3"> 

      <task type="joining" /> 

      <track video="-1" audio="-1" > 

        <clip src="C:\Test_part0.mp3" /> 

        <clip src="C:\Test_part1.mp3" /> 

        <clip src="C:\Test_part2.mp3" /> 

      </track> 

     </group> 

mk:@MSITStore:C:/Program%20Files/Solveig%20Multimedia/SolveigMM%20Video%20Splitter/Lang_Splitter/eng.chm::/SRC/techinfo.html#xtlformat_clip
mk:@MSITStore:C:/Program%20Files/Solveig%20Multimedia/SolveigMM%20Video%20Splitter/Lang_Splitter/eng.chm::/SRC/techinfo.html#xtlformat_clip
mk:@MSITStore:C:/Users/olga/Desktop/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter%205%20chm(eng)/SMMVSplitter.chm::/SRC/batchconsoleutil.html#xtlformat_group
mk:@MSITStore:C:/Users/olga/Desktop/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter%205%20chm(eng)/SMMVSplitter.chm::/SRC/batchconsoleutil.html#task
mk:@MSITStore:C:/Users/olga/Desktop/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter%205%20chm(eng)/SMMVSplitter.chm::/SRC/batchconsoleutil.html#xtlformat_track
mk:@MSITStore:C:/Users/olga/Desktop/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter/SolveigMM%20Video%20Splitter%205%20chm(eng)/SMMVSplitter.chm::/SRC/batchconsoleutil.html#xtlformat_clip
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    </timeline> 

</timelines> 

 

As a result, a file containing all parts specified in each clip in the specified order will be created.  

Slicing  

<timelines version="2" > 

  <timeline> 

     <group outdir="C:\Base\output\" outmask="[source]_[n:4]" > 

        <task type="autosplit" time="900000000" timeFormat="100ns_units" /> 

         <track video="1" audio="1" > 

           <clip src="C:\Base\avi\a.avi" start="begin" stop="end" 

timeFormat="position" /> 

         </track> 

      </group> 

   </timeline> 

</timelines> 

As a result, media file a.avi will be splitted into parts by time (1.5 minutes each one) and saved to C:\Base\output\ 

as separate files 

 

File with multiple audio streams trimming 

<timelines version="2" > 

   <timeline> 

     <group output="G:\output\Video_with_multiple_audio_tracks_0001.avi" > 

      <track video="1" audio="1" text="0" accuracy="gop" > 

        <clip src="C:\Users\olga\Videos\Video_with_multiple_audio_tracks.avi" 

start="128400000" stop="182800000" timeFormat="100ns_units" /> 

      </track> 

      <additional_param audio="2"/> 

      </group> 

    </timeline> 

</timelines> 

 

As a result, a file containing one video track and two audio tracks will be created and saved to G:\output\.  

The file consist of one fragment with the start time position 00:00:12;21 and end time position 00:00:18;07. 

 

File with external subtitles trimming 

<timelines version="2" > 

    <timeline> 

       <group output="G:\output\Video_0001.mp4" > 

          <track video="1" audio="1" text="0" accuracy="frame" > 

             <clip src="C:\Users\olga\Videos\Video.mp4" start="3410490416" 

stop="7623449166" timeFormat="100ns_units" /> 

           </track> 

         </group> 

         <group output="G:\output\Video_0001.HUNTA & Fratelli.ass" > 

            <track video="0" audio="0" text="1" > 

               <clip src="C:\Users\olga\Videos\Video.HUNTA & Fratelli.ass" 

start="3410490416" stop="7623449166" timeFormat="100ns_units"/> 

            </track> 
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         </group> 

      </timeline> 

</timelines> 

 

As a result, a file containing fragment with start time 00:05:41;00 and end time 00:12:42;03 and external ASS 

subtitles will be created. 

 

Technical information  

Video Splitter is based on the SolveigMM Video Editing SDK. 
Send any questions about the SolveigMM Video Editing SDK to the Solveig Multimedia Technical Support Team at 
support@solveigmm.com 

SolveigMM Video Splitter includes the following components: 

Component  File Name  Description  

 
COM \ ActiveX objects 

SolveigMM Video Editing Engine  SMM_EditEngine.dll  

COM object for GOP 
accurate AVI, Windows 
Media video, MPEG1 and 2, 
Windows Media audio 
trimming without 
decoding/encoding  

SolveigMM ActiveX time line control  SMM_OCXSlider.ocx  ActiveX time line control  

SolveigMM Frame Stepper  SMM_FrameStepper.dll  
COM object for frame/K-
frame navigation on media 
files  

SolveigMM Audio Silence Generation Library  SMM_SilenceGen.ax  

COM object for gettings 
samples for muted audio 
with different compression 
format.  

SolveigMM Audio Peak Reader  SMM_AudioPeakReader.dll  

COM object for getting 
amplitude peaks data for 
audio streams to display 
waveform  

 
DirectShow Trimmer Filters 

SolveigMM HEVC Video Trimmer Filter  SMM_HEVCVideoTrimmer.ax  
DirectShow filter for 
GOP/Frame accurate 
trimming HEVC video  

SolveigMM AVI Video Trimmer Filter  SMM_AVIVideoTrimmer.ax  
DirectShow filter for 
GOP/Frame accurate 
trimming video in AVI files  

SolveigMM-Elecard MPEG-2 Frame Accuracy 
Trimmer  

SMM_MP2FATrimmer.ax  
DirectShow filter for frame 
accurate MPEG-2 
Video/Audio trimming  

SolveigMM MPEG4 Trimmer  SMM_MPEG4TrimmerFA.ax  
DirectShow filter for MPEG4 
AVC GOP/Frame accurate 

mailto:support@solveigmm.com
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file trimming  

SolveigMM ASF Trimmer  SMM_ASF_Trimmer.ax   
DirectShow filter for frame 
and GOP accurate Windows 
Media Video files trimming  

SolveigMM AVC Video Trimmer Filter   SMM_AVCVideoTrimmer.ax  
DirectShow filter for 

GOP/Frame accurate 
trimming MPEG4 AVC video 

SolveigMM Audio Trimmer Filter  SMM_AudioTrimmer.ax     
DirectShow filter for 
trimming audio  

SolveigMM VP8 Video Trimmer Filter  SMM_VP8VideoTrimmer.ax  
DirectShow filter 
for  GOP/Frame accurate 
trimming VP8 video  

SolveigMM MP4V Video Trimmer Filter  SMM_MP4VVideoTrimmer.ax  
DirectShow filter for 
GOP/Frame accurate 
trimming MP4V video  

SolveigMM Subtitles Trimmer Filter  SMM_SubtitlesTrimmer.ax  
DirectShow fitler for 
trimming subtitles/text 
streams  

 
DirectShow Multiplexer/Demultiplexer 

SolveigMM ASF Multiplexer  SMM_ASFMuxer.ax  

DirectShow filter for the 
video and audio 
multiplexing into Microsoft 
Advanced Streaming 
Format.   

SolveigMM Wave format Multiplexer  SMM_WavMux.ax  
DirectShow filter for the 
audio multiplexing into 
Wave File Format  

SolveigMM MP4 format Multiplexer  SMM_MP4Muxer.ax   

DirectShow filter for video 
and audio multiplexing into 
QuickTime File Format and 
MPEG-4  

SolveigMM MP4 format Demultiplexer  SMM_MP4Demuxer.ax  

DirectShow filter for 
demultiplexing QuickTime 
File Format and MPEG-4 
Part 14 file format.  

SolveigMM FLV format Multiplexer  SMM_FLVMuxer.ax   
DirectShow filter for video 
and audio multiplexing into 
FLV File Format  

SolveigMM FLV format Splitter  SMM_FLVDemuxer.ax  
DirectShow filter for 
demultiplexing FLV File 
Format  

SolveigMM Matroska file format  Multiplexer  SMM_MKVMuxer.ax  
DirectShow filter for video 
and audio multiplexing into 
Matroska file format.  

SolveigMM Matroska file format Splitter  SMM_MKVSplitter.ax  
DirectShow filter for 
demultiplexing Matroska file 
format  

SolveigMM MPA format Demultiplexer  SMM_MPADemuxer.ax  

DirectShow filter for 
demultiplexing audio from 
MPEG audio format, and 

accurate navigation on 
Variable Bitrate MPEG audio 
files  
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DirectShow Encoders/Decoders 

SolveigMM Vorbis Audio Decoder    SMM_VorbisDecoder.ax  

DirectShow filter for 
decoding of Vorbis Audio. It 
is based on WebM project 
source code  

SolveigMM VP8 Video Decoder  SMM_VP8Decoder.ax    Decoder for VP8 video   

SolveigMM VP8 Video Encoder  SMM_VP8Encoder.ax  Encoder for VP8 video 

 
Others 

SolveigMM File Writer  SMM_FileWriter.ax  

DirectShow filter for writing 

AVI and MPEG audio files. It 
is used to keep A/V 
synchronization when AVI 
with MPEG VBR audio is 
trimmed  

SolveigMM K Frame Manager  SMM_KFrManager.ax  
DirectShow filter for 
providing the K frame 

navigation during playback  

SolveigMM Media Joiner  SMM_MediaJointer.ax  
DirectShow filter file-by-file 
audio/video joining.  

SolveigMM ASF Validator  SMM_ASFValidator.dll  
Library for Windows Media 
Video files validation.  

SolveigMM Thumbnails Generation Library  SMM_ThumbNail.dll  
Library for generation 
thumbnails from video files.  

SolveigMM Custom Encoder  SMM_CustomEncoder.dll  
Library for partial 
reencoding video fragments  

SolveigMM Timeline Editing Object  SMM_TimelineEditingObj.ax  
DirectShow filter that wraps 
trimming graph into one 
filter using  XTL Batch file  

SolveigMM Media File Chopper  SMM_MediaFileChopper.ax  

DirectShow filter that splits 
output into sequence of 
separate files with given 
duration or file size  

SolveigMM Trimm Graph Manager  SMM_TrimmGraphManager.ax  

DirectShow filter that 
manages trimming process 
in trimming graph. Works 
with trimmer filters: 

SMM_AVIVideoTrimmer.ax, 
SMM_AudioTrimmer.ax, 
SMM_AVCVideoTrimmer.ax, 
SMM_VP8VideoTrimmer.ax, 
SMM_MP4VVideoTrimmer.ax  

SolveigMM Subtitle Overlay  SMM_SubtitleOverlay.ax  
DirectShow filter for 
displaying subtitles.  

SolveigMM Timeline Preview Object  SMM_TimelinePreviewSource.ax  
DirectShow filter for the 
timeline set in the XTL 
format playback  
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