
 

 

Solveig Multimedia Video Splitter  
 
This documentation is designed to help you in using Solveig Multimedia Video Splitter. It contains information that 
describes basic and advanced steps for performing splitting tasks, interface items and shortcut keys. 
This documentation is divided into the following sections: 

 Getting started: This section contains introductory information about Solveig Multimedia Video Splitter, 
supported file formats, system requirements, basic terms and shortcut keys  

 Solveig Multimedia Video Splitter interface: Provides information about controls in the Solveig Multimedia 

Video Splitter user interface  
 Using Solveig Multimedia Video Splitter: Provides information about procedures to accomplish common 

tasks in Solveig Multimedia Video Splitter  

 How-To: Provides information about the basic steps of video splitting process  

 Technical information: Provides the technical description of the components Video Splitter is based on  

 
 
Notices 

SolveigMM Video Splitter  

User Guide 

 

Version 3.5  

SolveigMM Video Splitter User Guide 

First edition: August 18, 2005 

Date modified: September 27, 2012. 

For information, contact Solveig Multimedia 

Tel: +7 382-2-701-424; Fax: +1 (801) 991-5443 

More information can be found at: www.solveigmm.com 

For Technical Support, please contact the Solveig Multimedia Technical Support Team: support@solveigmm.com 

Solveig Multimedia provides this publication “as is” without warranty of any kind, either expressed or implied.  

This publication may contain technical inaccuracies or typographical errors. While every precaution has been taken 

in the preparation of this document, the publisher and author assume no responsibility for errors or omissions. Nor 
is any liability assumed for damages resulting from the use of the information contained herein. Changes are 

periodically made to the information herein; these changes will be incorporated in new editions of the publication. 
Solveig Multimedia may make improvements and/ or changes in the product(s) and/or the program(s) described in 

this publication at any time. 

Other company, product, service names and trademarks are trademarks or service marks of other companies or 

corporations.

 

 

http://www.solveigmm.com/
mailto:support@solveigmm.com


 

 

Getting started  
 
SolveigMM Video Splitter is a fast and powerful video splitting tool (see supported file formats). You can split your 

video file into parts with a few mouse clicks without any quality loss. 
It is also possible to cut out several file portions of a movie at one time. You can get rid of all commercials in your 

movie in a couple of simple steps. 
 

Since version 1.2, batch files are supported! For now you can add all your trimming tasks to a batch queue and 

process all of them at a time.  

In version 2.2, the join manager has been added. The manager allows to join multiple audio/video fragments. The 

reencoding is not involved in the joining process so all files must have the same parameters, such as video frame 
height/width, audio/video compression type, etc. 

In this section:  

 Basic terms: The explanation of concepts and terms referred to in this document  
 Supported file formats: The list of file formats that SolveigMM Video Splitter can handle  

 System requirements: Minimum and recommended system requirements for SolveigMM Video Splitter  

 Keyboard shortcuts: The list of keyboard shortcuts  

 

Basic terms 
 
This section explains the key terms referred to throughout this document. Understanding these terms will help you 

start using Solveig Multimedia Movie Splitter in the most comfortable way. 

 Splitting process  

 Joining process  

 Source and destination files  

 Markers  

 Basicterms fragments  

 

Splitting process 

Splitting is the process of dividing your video files into parts. For example, you can cut out a piece of video with 

undesired scenes (e.g. commercials, corrupted video). The splitting process leaves source files intact saving the 

result in the destination file. 

 

Joining process 

Joining is the process of combining multiple parts or fragments of video/audio into a single file. Joining does not 
involve reencoding so it does not affect the output audio/video quality. 

 
Source and destination files 
 
 
The source and destination files are the video files of a supported format. The source file contains video that you 



can split into parts, the destination file contains the final movie clip. During the splitting process, the source file 

remains in its original location and will not be changed or deleted. 

 

Markers 
A marker is a constituent part of a fragment. A fragment consists of two markers: start and end. It is set in the 
current cursor position. 

 

 
 
A selected marker is highlighted in yellow: 

 

 
 

Such operations as deleting and positioning are applied to selected markers only.  

 
Fragments 
 
A fragment is a part of a movie (or audio) file limited by two markers that is to be removed or kept in the final 

movie, e.g. the commercial block you need to be cut out. 
You can see sample fragments below:  

 

   
 

   
 

For more detailed color definition see Using splitting controls section.  

 

Supported file formats 

- SolveigMM Video Splitter supports the following media file formats: 

- AVI file format  

 any video content (DivX, DV, MJPEG, XVID, MPEG-4, etc.)  
 any audio content (MPEG-1/2 Layer 1/2/3, Dolby AC3, PCM, OGG, WMA, etc.)  
 AVI DV type1 and type2  
 any file size (more than 2 GB)  
 OpenDML AVI extension  

- WMV file format 

 any Windows Media video content (WM Video 7/9, MPEG-4 v 1/3, etc.)  
 any Windows Media audio content (WM audio 2/9, etc.)  
 non-indexed or damaged WMV files 

- ASF file format 

 any video content (DivX, MJPEG, XVID, MPEG-4, WM Video 7/9, etc.)  
 any audio content (MPEG-1/2 Layer 1/2/3, Dolby AC3, PCM, OGG, WMA, etc.)  
 non-indexed or damaged ASF files  

 
- MPEG Audio Format files (*.mp1, *.mp2, *.mp3, *.mpa)  



 MPEG-1 Layer I, II, III  
 MPEG-2 Layer I, II, III  

- MPEG-1 Video Format files (*.mpg, *.mpeg, *.m1v, *.mpv) 
 

- MPEG-2 Video Format files (*.mpg, *.mpeg, *.mpv, *.m2v, *.vob) 
 

- MOV file format files (*.mov) 

 
- MP4 file format files (*mp4) 

 
- MKV file format files (*mkv) 

 

- AVCHD file format files (*m2ts, *mts) 
 

- WEBM file format files (*webm) 

- Indexation supports the following file formats:  

- MPEG-1 Video Format files (*.mpg, *.mpeg, *.m1v, *.mpv) 

 
- MPEG-2 Video Format files (*.mpg, *.mpeg, *.mpv, *.m2v, *.vob, *.ts, *.m2ts, *.vob) 

 

System requirements 

Software Requirements  

 Windows® 98/Me/2000/XP  
 DirectX 8.0 Runtime or higher  
 Video and audio decoders for the preview feature (DirectShow, VFW or DMO)  
 WMV/ASF support requires Windows Media Format 9 Series Runtime (shipped with Windows Media Player 

9 and higher) MS: http://www.microsoft.com/windows/windowsmedia/9series/player.aspx 

Hardware Requirements  

 CPU (Intel® Pentium II, Celeron, AMD® Athlon, Opteron etc.)  
 128 MB RAM  
 Any VGA card  
 About 100 MB of free disk space  

 

Keyboard shortcuts 
 
Almost every procedure in SolveigMM Video Splitter can be done using shortcut keys. Using these shortcut keys 

you can do some tasks more quickly. 

The table below provides the list of operations that you can perform using keyboard shortcuts. 

 
Hot Keys of Video Splitter (main window): 

Operation Shortcut key 

Next K frame Right arrow 

Previous K frame Left arrow 

Next frame Ctrl + Right arrow 

Previous frame Ctrl + Left arrow 

Jump 2 min forward Shift + Right Arrow 

Jump 2 min backward Shift + Left Arrow 

http://www.microsoft.com/windows/windowsmedia/9series/player.aspx


Jump 1/20th of the movie length forward  Page Up  

Jump 1/20th of the movie length backward Page Down  

Jump to movie end End  

Jump to movie start Home  

Zoom in NumPad + 

Zoom out NumPad - 

Maximize zoom NumPad / 

Reset zoom NumPad * 

Move scaled area right Alt + Right Arrow 

Move scaled area left Alt + Left Arrow 

Play/Pause Space 

Add marker  M  

Remove marker(s) Delete 

Clear all markers Ctrl + C 

Select next marker Tab 

Select previous marker Shift + Tab 

Select slider cursor Ctrl + Tab 

Keep the selected fragment S 

Cut out the selected fragment D 

Invert time line fragments I 

Calculate destination file size ( available for AVI, MP3 ) Ctrl + F  

Start the splitting process Ctrl + T  

Show the batch manager  Ctrl + B  

Add a task the to batch queue  A  

Help topics F1  

Hot Keys of Batch Manager:  

Operation Shortcut key 

Load a task list  Ctrl + O  

Save a task list Ctrl + S  

Add a task to the batch queue  A  

Update a task in the batch queue  U  

Delete the selected task or fragment Delete 

Start the batch processing Ctrl + T  

Start the batch processing for the selected tasks Shift + T  

Edit the task in main window or show the selected 
fragment in the main window  

Enter 

Select all tasks Ctrl + A 

 

Hot Keys of Join Manager:  

Operation Shortcut key 

Add media file(s) to the list  Ins  

Delete the selected files from list Del  

Move the selected item down  PgDown  

Move the selected item up  PgUp  

 
 



 

 

Solveig Multimedia Video Splitter interface 

The Solveig Multimedia Video Splitter user interface consist of five main parts: Menu bar, Navigation controls, 

Information window, Splitter controls and Preview window. 

SolveigMM Video Splitter main window:

 

Batch manager window: 

 

 



In this section:  

 Menu bar  

 Navigation controls  

 Information panel  

 Splitting controls  

 Preview window  

 Progress window  

 Splitter in system tray  

 Filters info window  

 Batch manager  

 Join manager 
 Preferences window  

 

Menu bar 
You can use commands in the menu bar to perform tasks in Solveig Multimedia Video Splitter. These commands 

are described in this document. 
 

 
 
File menu 
 

 

Menu item Description 

Open media file... Select a supported media file to be opened and edited (*) 

Save media file as... 
Specify the output file name and immediately save it (start the trimming 

process) or add it to the batch queue (*), (**) 

Save All Fragments 
As... 

Specify the output file name and immediately save it (start the trimming 
process) or add it to the batch queue (*), (**) 

Close Close the input and output files  

Load project... Open a SolveigMM Video Splitter project file  

Save project as... Save the project file 

Load Batch List... Load a task list to the Batch Manager 

Save Batch List As... Save the batch list 

Load Join List... Load a join list to the Join Manager 

Save Join List As... Save the join list 

Recent File... Open the recently edited file 



Exit Close the program 

 
(*) - These operations are also alvailable from the information panel. 

(**) - To add a task to the batch queue, you should select the Don't start now. Add the task to batch queue 
instead checkbox in the Save As dialog box as shown below:  

 

 

Edit menu 

 

 

Menu item Description Shortcut key 

Undo (Add Marker)  Undo the action  Ctrl + Z 

Redo  Redo the action Ctrl + Y 



Stop  Stop playback  
 

Play  Start playback Space 

Pause  Pause playback Space 

Add Marker  Add a new marker (*)  M 

Remove Marker(s)  Remove the selected marker or markers (*)  Delete 

Keep Selected Fragment Keep the selected fragment (*) S 

Cut Out Selected Fragment Cut the selected fragment (*) D 

Clear All Markers  Remove all markers  Ctrl + C 

Invert Time Line Fragment  Invert all timeline fragments on the slider (*)  I 

Calculate Destination File 
Size  

Calculate destination file size (available for AVI, MP3)  Ctrl + F 

Start trimming  Start the trimming process (*) Ctrl + T 

 
(*) - These operations are available from the menu and from the context menu . For details, see Navigation 

controls, Information panel, Splitting controls 

View menu 

 

Menu item Description Shortcut key 

Time format Opens the submenu - 

Show frames thumbnails Allows to show or hide frames thumbnails - 

Show format switch 
warnings 

Allows to turn off or turn on format switch warnings - 

Zoom Opens the submenu - 

View menu -> Time format 

 

Menu item Description Shortcut key 

Times and frames Allows to show timeline in HH:MM:SS;frames format - 

Time Allows to show timeline in HH:MM:SS;ms format - 

 

 

 



 

View menu -> Zoom  

 

Menu item Description Shortcut key 

Move Scaled Area Right Move the zooming scrollbar right Alt + Right Arrow 

Move Scaled Area Left Move the zooming scrollbar left Alt + Right Arrow 

Zoom In Zoom in the timeline slider NumPad + 

Zoom Out Zoom out the timeline slider NumPad - 

Maximize Zoom Set the max scale rate  NumPad / 

Reset Zoom Reset the scale rate to 1 (initial scale) NumPad * 

 
Navigation menu 
 

 

Menu item Description Shortcut key 

Next K Frame Go to the next K Frame Right Arrow 

Previous K Frame Go to the previous K Frame Left Arrow 

Next Frame Go to the next Frame Ctrl + Right Arrow 

Previous Frame Go to the previous Frame Ctrl + Left Arrow 

Jump to 2 min Forward Jump 2 minutes forward Shift + Right Arrow 

Jump to 2 min Backward Jump 2 minutes backward Shift + Left Arrow 

Jump to 1/20th Forward Jump 1/20th of movie length forward Page Up 

Jump to 1/20th Backward Jump 1/20th of the movie length backward Page Down 

Jump to Movie End Jump to the movie end Home 

Jump to Movie Start Jump to the movie start End 



Select Next Marker Select the next marker Tab 

Select Previous Marker Select the previous marker Shift + Tab 

Select Slider Cursor Select the slider cursor Ctrl + Tab 

 

Control menu 

 

Menu item Description 

Frame Accuracy 
(Smart Mode) 

Enable the frame accurate trimming mode 

Obey samples times 
Use an alternative synchronization algorithm. By default, it is disabled. If the resulting file 

is out of sync after repeated trimming selecting this option should improve audio/video 

synchronization. 

Video and Audio 
streams 

Select audio and/or video streams to be rendered into the final movie. For details, see 
Using Solveig Multimedia Video Splitter. 

Ignore Trimming 
Errors 

Ignore trimming errors. 

 
Note: It is recommended to keep it disabled by default.  

Slider K-Frame 
Positioning 

If this option is enabled, the cursor jumps to the nearest previous K Frame after you 
position the slider. This mode implements the What You See Is What You Get feature. 

If this option is disabled, you can navigate through all movie frames.  

Markers K-Frame 
Positioning 

If this option is enabled, the marker jumps to the nearest previous K Frame after you 
position it. This mode implements the What You See Is What You Get feature. 

If this option is disabled, you can set the marker at any movie frame. 

 
Note: If the start marker of a fragment is disabled, the fragment in the final movies will 

be started with the K Frame anyway. 
Note: If the end marker of a fragment is disabled, the fragment in the final movies will 

end with the frame at the marker position.  

 
Tools menu 

 



 
 

Menu item Description 

Batch Manager Open the sumbenu of the Batch Manager item 

Join Manager Open the Join Manager window  

Time Calculator Show the time calculator 

History List Open the history list of actions 

Index MPEG files in 

folder... 
Create index for MPEG files in the selected folder  

Index MPEG File Create index for the MPEG2 video file (*)  

Explore Folder Open Windows Exporer in the folder with the Input or Output media files 

Logging Open menu for actions with log files 

Show Preview filters Show the list of filters used for preview 

Preferences... Open preferences window 

 

(*) - This operation is available for MPEG2 video only if the file has not been indexed yet.  
 
Tools -> Batch Manager menu 
 

 
 

Menu item Description Shortcut key 

Show Batch 

Manager 
Show the Batch Manager window Ctrl + B 

Load Task List... Select a supported batch file  
 

Save Task List As... Save the Task List containin trimming task descriptions to an *.xtl file. 
 



See the Task List syntax in Batch file format 

Add Task To Batch 
Queue 

Add the current task to the batch queue A 

Update task Update the selected task in the batch queue  
 

Start Batch 
Processing 

Start the batch processing 
 

 
 

 

Tools -> Join Manager menu 
 

 

Menu item Description 

Load Join List Load a joining task from a file  

Save Join List Save the current joining task to a file 

Show Join Manager Show the Join manager main window 

Join Manager Tooolbar Show/hide the Join manager toolbar window  

 

Help menu 

 

Menu item Description Shortcut key 

Help topics... Open the help file F1 

Keyboard ShortCuts Shows the Keyboard Shortcuts section in the help file 
 

Video Splitter on Web Open the Solveig Multimedia web pages and forum. 
 



Register... Register SolveigMM Video Splitter 
 

Product Comparison Open comparison table of SolveigMM products 
 

Check for updates Check if the latest Video Splitter version is installed 
 

About SolveigMM Video 

Splitter 
Open the About dialog box 

 

Languages Set language for Video Splitter interface 
 

 
 

 

  

 

 

Navigation controls 

Navigation controls are designed for navigation through an open source media file. Using these controls, you can 
start and stop playback, pause it or search for the necessary position forward and backward. Also, the current 

position and total duration are displayed.  

 

Window item Description Shortcut key 

 
 

 

Previous K Frame  
 

Next K Frame 

Left arrow 
 

Right arrow 

 

Play/Pause  Space 

 

Pause  
 

 
 

 

Previous Frame  

 

 
Next Frame 

Cntr + Left 

arrow 
 

Cntr + Right 
arrow 

 

Slider cursor time position. You can edit this value manually  
 

 

Total file length 
 

 

 

 

 

 

 

 

 

 



Information panel 

 

The Input section of the Information panel shows you the following input media file information:  

Field Description 

File Source filename 

Duration Media file duration in HH:MM:SS;frames or in HH:MM:SS;ms 

ByteSize Source file size 

Video Video encoding type 

Audio Audio encoding type 

 
The Output section of the Information panel shows you the following information:  

Field Description 

File Output filename 

Size Output file size 

Selection 

Selected fragment Information:  

Start Position 
Stop Position 

Type (Cut/Keep) 

 
Note:  

All Information Panel values are shortened. To see the full value (e.g. full filename with the path), just move the 

mouse pointer over the value and the full version will appear both in the tooltip and on the status bar as shown 
below: 

 
Note:  

All the values can be copied to the cplipboard via the context menu.  
 



 
 
Also, the information panel contains quick buttons: 

Button Description 

 

Open Media File...  

 

Save Media File As...  

 
These operations are also available from the File menu 

 

Splitting controls 
 
Splitting controls are the heart of Solveig Multimedia Video Splitter. Using this controls, you can manage the 
fragments that will or will not be saved in the final movie. You can set fragments to be cut or kept, invert or 

completely delete fragments from your movie. Finally, the main button that starts the splitting process is located 

on this panel. 
 

 

Window Item Description Shortcut key 

 

 

Add Marker: Add a new marker to the current slider cursor position. 

 
Remove Marker(s): Remove the current marker or fragment 

M 

 
Delete 

 

Keep Selected Fragment: Set the fragment type 

 
Cut Selected Fragment: Set the fragment type 

S 

 
D 



 

 

Invert: Invert time line fragments I 

 

Size: Calculate the final file size (available for AVI, MP3) Ctrl + F 

 

Trim: Start trimming or batch processing (if there are any tasks in the 

batch queue) 
Ctrl + T 

 

Left marker cursor time position. You can edit this value manually  
 

 

Right marker cursor time position. You can edit this value manually  
 

 
 

 

Zoom In: Increase the slider timeline resolution to make editing 
neighbouring markers more comfortable (*) 

 
Zoom Out: Decrease the slider timeline resolution (*) 

NumPad + 
 

NumPad - 

 

 
Story board Off/On: turn off/on the story board  

 

 

Save current fragment as: saves the selected fragment 
 

 

Save All fragments as: saves all selected fragment on the timeline 
 

 

Add Task to Batch Queue: adds task to the batch queue to edit it later 

with Batch Manager  

(*) - To view timeline areas after Zoom In, you can use the scrollbar (below the timeline slider) and the Alt + 

Left arrow and Alt + Right Arrow hot keys. 

Sample fragments: 

Fragment color Description 

 

This fragment is set to be deleted. It will not be present in the final movie 

 

This fragment is set to be kept. It will be present in the final movie 

 

This fragment is set to be deleted. It will not be present in the final movie. 

The yellow color means you can edit it (delete, set it to be kept, etc.) 

 

This fragment is set to be kept. It will be present in the final movie 

The yellow color means you can edit it (delete, set it to be cut, etc. )  



Slider context menu 

 

 

Menu item Description Shortcut key 

Save Selected Fragment 

As... 

Specify the output filename and immediately save the selected fragment 

(start the trimming process) or add the selected fragment to the batch 
queue (*)  

Set New Marker Add a new marker to the current slider cursor position M 

Remove Marker(s) Remove the current marker or fragment Delete 

Keep On Selected 

Fragment 
Sets the type of the selected fragment to be kept S 

Cut Off Selected Fragment Set the type of the selected fragment to be cut D 

Invert Time Line Fragments Invert time line fragments I 

Clear All Markers Remove all markers Ctrl + C 

(*) - To add the task to the batch queue, you should select the Don't start now. Add the task to batch queue 
instead checkbox in the Save As dialog box as shown below: 
 

 



Preview window 

 
The preview window is designed for easy navigation through media files and helps you put splitting markers as 

precisely as possible. 
 

 

 

Progress window 

The progress window indicates the current progress in percentage terms. You can cancel splitting by clicking the 
Cancel button or hide Splitter to the system tray by clicking the Hide button. 

 

 
 

The Batch Processing progress window is shown below: 
 

 



 

The upper progress bar shows the progess of the task being berformed 
The lower progress bar shows the progess of all the tasks in the batch queue 

 
The Hide button hides Splitter to the system tray.  

When trimming is complete, the Splitter window appears. 

 
See also Splitter in system tray 

 
 

Splitter in system tray 

When you click the Hide button, Video Splitter is hiden to the system tray. 

 

The following context menu is available when Video Splitter is in the system tray: 

 

Menu item Description 

Show Program Restore Video Splitter from the system tray 

Show Progress Show the current progress 

Exit Program Cancel the trim process and exit 

 

The following progress information will be shown if you click the Video Splitter system tray icon: 

One trimming task: 

 

Batch processing: 

 



 
Filters info window 
 
This window contains all the components necessary for Video Splitter to work properly. 

1. Click the icon of in the upper left corner of the window (You can use the Alt + Space shortcut)  
2. Click Info...  

 
 

 

Batch manager window 

 

 
The Batch Manager window is used to edit the batch queue.  

Menu description:  

 
 
 
 



File menu  

 

Menu item Description Shortcut key 

Load Task List... Load a saved batch queue from a file (*)  Ctrl + O 

Save Task List As... Save the batch queue to a file Ctrl + S 

Open Task List in 

Notepad 
Open the batch queue in Notepad (*) 

 

Hide Close this window 
 

(*) - See Task List syntax in Batch file format 
 
Edit menu 
 

 

Menu Item Description Shortcut key 

Add Task To Batch Queue Add the current Video Splitter task to the batch queue A 

Update task 
Update the task in the batch queue according to the changes made 
in Video Splitter 

U 

Edit Task with Video 

Splitter 
Edit the selected task in the Video Splitter main window Enter 

Delete Selected Task(s) Delete the selected task(s) Delete 

Delete Selected Fragment Delete the selected fragment(s) Delete 

Change Selected Task(s) 

Out Folder 
Change the output folder for all selected files. The program will not 

change the output filenames  

Start Batch Processing Start batch processing Ctrl + T 

Start Batch Processing For 

Selected Task(s) 
Start batch processing for the selected tasks Shift + T 

Preferences Open preferences window Ctrl + T 

 
 



Log menu 
 

 

Menu Item Description 

Show log Show or hide the log window 

Write log 

file... 
Specify the filename all the messages will be written to during the batch manager operation. 

Save log as... Save all log messages to a file 

Clear log Erase all messages 

 

Task queue field: 

The list enumerates all tasks in the batch queue: 

 

Column description:  

Menu Item Description 

Task # Task number 

Source file Source filename 

Dest file Destination filename 

Fragments count Number of fragments to be cut 

Full time Total final file length 

Audio stream Audio stream number (*) 

Video stream Video stream number (*)  

Obey samples times 
Use an alternative synchronization algorithm. By default, it is disabled. If the 
final file is out of sync after repeated trimming, enabling this option should 

improve audio/video synchronization. (*) 

(*) - These fields can be edited in the batch manager window. Just click the cell with the left mouse button two 
times (not a double-click) or click the mouse wheel. You can select the necessary item from the drop-down list 

depicted below. 
 

 
Changing settings in the task list window 

 



 

Context menu description: 

 

Menu item Description Shortcut key 

Save Task List As... Save the batch queue to a task list file. Ctrl + S 

Load Task List... 
Load a batch queue from a task list file  

See Task List syntax in Batch file format  
Ctrl + O 

Start Batch Processing Start batch processing Ctrl + T 

Start Batch Processing For 

Selected Task(s) 
Start batch processing for selected task(s) Ctrl + T 

Delete Selected Task(s) Delete the selected task(s) Delete 

Edit Task with Video 
Splitter 

Edit the selected task in the main window Enter 

Select All Select all tasks Ctrl + A 

Change Selected Task(s) 
Out Folder 

Change the output folder for all selected files. The program will 
not change the output filenames  

Change Source File 

Name... 
Change Dest File Name... 

Change the source or destination filenames. This item is available 
in the Source File and Dest File columns only.  

Copy Source File Name 
Copy Dest File Name 

Copy the source or destination filename to the clipboard. 
This item is available for the Source File and Dest file columns 

only.   

 

Fragment list 

 
 
All the fragments to be cut out from the selected task are enumerated here. 

 
Fragment list context menu  



 

 

Menu item Description Shortcut key 

Delete Selected Fragment Delete the selected fragment Delete 

Show the Fragment in 

Video Splitter 
Show and select the fragment in the Video Splitter main window Enter 

 

 

Join manager window 

 

Join manager is used to join file with equal parameters like width/height of the frame, video/audio compression 
etc. Currently supported formats are listed here. The list enumerates all files to be joined together. Only the whole 

files can be joined for now. 

 
Columns description:  

Menu Item Description 

#  File order  

Source file  Source file name  

Full time  Full time of current file to be appended to resulting file 

Start time  Start time of the current fragment of the current file(*)  

End time  End time of the current fragment of the current file(*)  

Audio  Audio encoding  

Samples/sec  Audio sampling frequency  

Mode  Audio mode 

Bitrate Audio bitrate 

Video Video compression 

Width Video frame width 

Height Video frame height 

Type the file type 

(*) - only full files can be joined so start time is the beginning of the file and end time is the duration of the file.  

 

 

 



Menu description:  

Menu "File"  

 

Menu item Description Shortcut key 

Add Media File(s) Add files into the list(*)  Ins 

Save Join List Save current joining task into the file 
 

Load Join List Load current task from the file 
 

Start Joining Start the joining progress for the current task 
 

(*) - if you try to add files with different parameters you will be prompted with the appropriate message in the 
satus bar of the "Join manager". 

 
Menu "Edit"  
 

 

Menu Item Description Shortcut key 

Move Up Move selected file up in the list Page Up 

Move Down Move selected file down in the list Page Down 

Delete Selected Items Delete all selected items from the list Del 

Clear List Delete all items from the list 
 

 
 

Context menu:  

 



The context menu commands duplicate menu commands for convenience, and it's "Add" and "Move" commands 

are applied to chosen file in the list ( the highlighted one ). Others are applied to the list in general. 

 
Join manager toolbar: 
 

 
 
The toolbar also duplicate some commands that allow you to perform joining not opening the main Join Manager 
window. 

Toolbar Item(left to right) Description 

Start Joining Starts current joining task 

Show / Hide Shows / Hides the Join manager main window 

Add File(s) Adds files into the list 

Load List Loads joining task from file 

 

 

Preferences window 

"Hot Keys Settings" tab 
 

 



 

Video Splitter allows to choose the defined settings of your desired hot key profile.  

Simply enter your hot key for the chosen operation (right column), click Yes in the appeared information window 
and then enter the desired name for the new profile, then click on the OK button. The new profile will appear in 

the Current Profile combobox.  

 

You can remove your profile by selecting the needed one in the "Current profile" combobox and clicking on the 

Remove button.  

 

"Codecs and settings" tab 

 

 

 
Codecs and Settings window allows to choose the decoder and encoder that will be used in re-encoding process of 

first and last GOP when frame accuracy trimming (Smart Mode) is enabled.  



To select the desired codeс, choose one or several from the Encoder/decoders list and press the Force 

selected button.  
The chosen codec will appear in the Preferred codecs list.  

You can choose several codecs from the Encoder/Decoder list. All they will be placed to preferred codec 
"Preferred codecs" area.  

 

Important notice: the decoder or encoder can be forced only for WMV and MP4 (with MP4 Visual video). 
 

Video Splitter uses codec that will be suitable for the format of the opened file.  
You can use Move Up and Move Down buttons, to change the priority of the chosen codec.  

 

"Audio Waveform" tab 

 

 

 
"Waveforms files path" setting defines waveform data cache path, that is used by Video Splitter. 

 
"Follow the slider while the waveform is constructed" defines the way of wayform building. When the 

option is enabled the wayform will be build from the selected by the user slider position. Tick this checkbox if you 
would like the wayform building follow the slider movements.  

 

If you would like you can change the file path for this file to keep free space on the system drive. 

 

 



"Output Files Mask" tab 

 

 
 
The files mask is intended to generate the names of the output files, using build-in macroses.  

The mask is the template that consists of macroses.  

It is possible to add predefined macros using special buttons under the "Mask of output file names" line to 
current cursor position at template edit box.  

 
[source] macros defines the input file name. 

 

[n] macros is the current number of fragment, that can be used in the template of the output file name.  
 

[n:4] macros is the current number of fragment with defined minimum number of characters printed. Zeros are 
added to the left of the values.  

 
[time] macros is intended for defining the current date time of the output file name. 

 

To add the required macros just click on the button with the macros name and then change it in the Mask of the 
output files names field if needed. 

 
You can change the order of this macroses to get the files with names that will be suitable for you.  

 

To reset the mask to initial view, just click on the Reset to defaults button. 
 

Below please find examples of mask templates and the output files names.  
 

Admit we have the Video.avi input file and would like to save three fragments from the file. We make this 
operation on September 25, 2012 at 18:50:30. 



 

 

The mask template The output file name 

[n] 
1.avi 
2.avi 

3.avi 

[source]_[n] 
Video_1.avi 

Video_2.avi 
Video_3.avi 

[source]_[n:2] 

Video_01.avi 

Video_02.avi 
Video_03.avi 

 

[source]_[time] 
Video_2012_09_25_18_50_30.avi 

Video_2012_09_25_18_50_30.avi 
Video_2012_09_25_18_50_30.avi  
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Using Solveig Multimedia Video Splitter 

In this section:  

 Opening a source file  

 Using the splitting controls  

 Saving a media file  

 Starting the trimming process  

 Working with the batch queue  

 Working with MPEG-2 files  

 

Opening a source file  

Operations with files are performed via the menu bar in Solveig Multimedia Video Splitter. 

To open a source file, go to the menu bar, select File -> Open Media File... Select your video file in standard 

Open File dialog box. This file will not be changed, deleted or moved during the splitting process. 

To set the destination file, select File -> Output File... and specify the name for the destination file. If a file with 
the same name already exists, you will be asked if you want to replace the old file with the new one. You can 

overwrite the old file or specify a new filename for the destination file. 

See also: File menu, Information panel 

 

Using the splitting controls  

Before you start the trimming process, you should define the fragments you want to be cut or kept in the output 
file. 

To add a new fragment to the slider: 

1. Navigate to the beginning of the future fragment.  

2. Press the Set new marker key (M) or select the Edit -> Set New Marker menu item from the menu bar  

3. Navigate to the end of the future fragment.  

4. Repeat step 2.  

5. Set the fragment type by selecting Edit -> Cut Off Selected Fragment (D) or Edit -> Keep On Selected 

Fragment (S).  

6. If you need to change the start or stop fragment positions, just drag the markers to their new positions. 

 



 

Sample fragments  

Fragment color Description 

 

This fragment is set to be deleted. It will not be present in the final movie 

 

This fragment is set to be kept. It will be present in the final movie 

 

This fragment is set to be deleted. It will not be present in the final movie. 

The yellow color means you can edit it (delete, set it to be kept, etc.) 

 

This fragment is set to be kept. It will be present in the final movie. 

The yellow color means you can edit it (delete, set it to be cut, etc. ) 

 

Window Item Description Shortcut key 

 

 

Add Marker: Add a new marker to the current slider cursor position. 

 

Remove Marker(s): Remove the current marker or fragment 

M 

 

Delete 

 

 

Keep Selected Fragment: Set the fragment type 

 

Cut Selected Fragment: Set the fragment type 

S 

 

D 

 

Invert: Invert the time line fragments I 

 

Size: Calculate the output file size (available for AVI, MP3) Ctrl + F 

 

Trim: Start trimming or batch processing (if there are any tasks in the 

batch queue) 
Ctrl + T 

 

Left marker cursor time position. You can edit this value manually 
 

 

Right marker cursor time position. You can edit this value manually 
 

 

 

Zoom In: Increase the slider timeline resolution for editing neighbouring 

markers more comfortably (*) 

Zoom Out: Decrease the slider timeline resolution (*) 

NumPad + 

NumPad - 

 Story board Off/On: turn off/on the story board 
 



 

 

Save current fragment as: saves the selected fragment 
 

 

Save All fragments as: saves all selected fragment on the timeline 
 

 

Add Task to Batch Queue: adds task to the batch queue to edit it later 

with Batch Manager 
 

 

Starting the trimming process  

To start the trimming process after you set all the fragment you want to be deleted/saved, select File -> Save 

Media File As... (for details, see File menu) or click the Save Media File As.. quick button (for details, see 
Information panel or click the Trim button (for details, see Splitting controls)  

 
Note: You can save (trim) any selected fragment using the Save Selected Fragment As.. item from the slider 

context menu (for details, see Splitting controls)  

 

Working with the batch queue  

To create a new batch queue (task list):  

1. Open the media file you want to edit, set all the fragments you want to be saved/removed. For details, see 

Opening source file and Solveig Multimedia Video Splitter interface  

2. Add the task to the queue. To do it, select Tools->Batch Manager->Add Task To Batch Queue 

3. Repeat steps 1 and 2 for all the files you want to process. 

See also Tools menu, Keyboard shortcuts 

 

Also, you can add a task to the queue by selecting File -> Save Media File As... from the menu, or clicking the 

Information panel quick button, or selecting the Save selected fragment as.. item from the slider context menu 

(for details, see Splitting controls). You should select the Don't start now. Add the task to batch queue 

instead checkbox as shown below:  

 



 
 

To open the Batch Manager window, select Tools -> Batch Manager -> Show Batch Manager on the menu or 

select Tools -> Batch Manager -> Load Task List... to open a task list file.  

The Batch Manager window allows you to change audio/video streams, the Obey samples times attribute, 

delete any fragments, etc. For details, see Tasks queue field.  

To edit a task, you have to open it in Video Splitter, change its fragments or settings and update it: 

1. Select the task you need to edit. Select the Edit -> Edit Task with Video Splitter menu item or the Edit 

Task with Video Splitter item from the context menu or press the Enter hot key. For details, see Tasks queue 

field, Keyboard shortcuts  

 

2. Edit the task in the Video Splitter main window. To view the existing fragments in Video Splitter, you can use 

the Fragment list field. To do it, select Show the Fragment in Video Splitter from the context menu or press 

the Enter hot key. For details, see Keyboard shortcuts  

 

3. After you edit the trimming settings in Video Splitter, update the task in the batch queue by selecting the Tools 

-> Batch Manager -> Update Task menu item or the Edit -> Update Task item in the Batch Manager 

window. 

 

Working with MPEG-2 files 

This section describes how to use SolveigMM Video Splitter with MPEG-2 video.  
 
Open the MPEG-2 video file you want to split: 

Select File -> Open Media File... from the menu.  



 

The standard Windows Open File dialog box will appear.  
 

 
 
The Don't index now checkbox is used to prevent SolveigMM Video Splitter from indexing the MPEG-2 video file 

automatically.  
 

Select the video file and click Open.  
 

Note. Indexing the MPEG file is recommended but not required.  



With no index, you will not be able to use K-Frames and the trimming process can be inaccurate. 

 

 

 
If you cancel the indexing process or choose not to index the file, you can index it later in the following way: 
select Tools -> Index file from the menu.  

If the source file was changed there will be the following message: 

 

 

Note: It is recommended to press the Yes button for Video Splitter could update the index file.  

What to do next is described in How-to section.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

How to... 

 register Solveig Multimedia Video Splitter  
 open a video file  
 preview a video clip  
 navigate in your video  
 set and delete markers  
 set fragments to be kept or cut  
 select video and audio streams  
 fix audio/video synchronization  
 start splitting  
 start joining  

 

How to register Solveig Multimedia Video Splitter 

To register Solveig Multimedia Video Splitter, please do the following:  

1. Launch SolveigMM Video Splitter 

2. Press ''Activate'' button to start registration 

 



3. Enter your license code into the opened window and press ''Activate'' button. 

 

Registration completed! 

 

How to open a video file 

To open the video file you want to split, do the following: 

1. Select File -> Open Media File... from the menu. The standard Windows Open File dialog will appear.  
2. Find your video file and click Open. 

 

 

 

See also Supported file formats, File menu 

 

How to preview a video clip 

1. Open a video file  
2. To start playback, click the Play button. Also, you can use the Edit->Play menu item or the Space 

shortcut key.  
3. To pause playback, click the Pause button. You can use the Edit -> Pause menu item or the Space 

shortcut key.  

Window 

element 
Description Shortcut key 

 

Previous K Frame 

 
Left arrow 



 
Next K Frame Right arrow 

 

 

Play/Pause Space 

 

 

Next Frame 

 

Previous Frame 

Cntr+ Right arrow 

 

Cntr+ Left arrow 

 

See also Navigation controls, Edit menu, Keyboard shortcuts 

 

How to navigate in your video 

1. To advance to the next K frame, click the Next K Frame button or select the Edit->Next K Frame 
menu item from the menu. You can also use the Right arrow shortcut key.  

2. To jump to the previous K frame, click the Previous K Frame button or select the Edit->Previous K 
Frame menu item. The Left arrow shortcut key is also available.  

3. Left-click the timeline at the position you need.  
4. Type the necessary time in the edit box in the Navigation controls in the HH:MM:SS.mS format. The 

position will be automatically adjusted to the nearest previous K frame.  

Window 

element 
Description Shortcut key 

 

 

Previous K Frame 

 

Next K Frame 

Left arrow 

 

Right arrow 

 

 

Previous Frame 

 

Next Frame 

Cntr+ Left arrow 

 

Cntr+ Right arrow 

 

See also Navigation controls, Edit menu, Control menu, Keyboard shortcuts 

 

How to set and delete markers 

To set a new marker, do the following:  

1. Navigate to the position where you want to add it.  
2. Press the Set new marker key (M) or select the Edit -> Set New Marker menu item  

To delete a marker:  

1. Left-click the marker you want to delete.  
2. Press Remove marker/fragment key (Delete) or select the Edit -> Remove marker or markers 

menu item. 



To delete all markers from the timeline, select the Edit -> Clear All Marks menu item or use the Ctrl + C 

shortcut Note: markers will be deleted without any confirmation  

Window element Description Shortcut key 

 

 

Add a marker  

Remove the marker(s) 

M  

Delete 

 

 

See also Edit menu, Keyboard shortcuts, Splitting controls 

 

How to set fragments to be kept or cut 

 

To define a new fragment:  

1. Navigate to the beginning of the future fragment.  
2. Press the Add a marker key (M) or select the Edit -> Set New Marker menu item.  
3. Navigate to the end of the future fragment .  
4. Repeat step 2. 

To adjust the time of the fragment start and stop: 

1. Select the marker at the beginning/end of the fragment  
2. Drag the marker to the necessary position (or use the Next K Frame/Previous K Frame buttons)  

To delete a fragment: 

1. Left-click the fragment you want to delete.  
2. Press the Remove marker/fragment key (Delete), or select the Edit -> Remove marker or markers 

menu item. 

Note: the fragment will be deleted without any confirmation. 

To set a fragment to be kept 

1. Left-click the fragment you want to keep.  
2. Press the Keep On Selected Fragment key (S) or select the Edit -> Keep On Selected Fragment 

menu item. 

To set a fragment to be cut 

1. Left-click the fragment you want to delete.  
2. Press the Cut Off Selected Fragment key (D) or select the Edit -> Cut Off Selected Fragment menu 

item. 

Window 

element 
Description Shortcut key 

 

 

Add Marker: Add a new marker to the current slider cursor position. 

 

Remove Marker(s): Remove the current marker or fragment 

M 

 

Delete 



 

 

Keep Selected Fragment: Set the fragment type 

 

Cut Selected Fragment: Set the fragment type 

S 

 

D 

See also Edit menu, Keyboard shortcuts, Splitting contros 

 

How to select video and audio streams 

Solveig Multimedia Video Splitter allows you to choose the audio and video streams that will be rendered into the 

final movie. To choose the streams, open the Control menu: 

 

 
 

All video/audio streams the input media file contains are enumerated in the lower part of the menu. 

Choose the streams you want to be present in the output file. 

 

Only the audio stream will be saved in the example. 

 

See also Control menu  

 

How to fix audio/video synchronization 

Solveig Multimedia Video Splitter is designed to split media files without loosing audio/video synchronization. 

However, some media files lose synchronization after splitting. To avoid losing sync, you can try to do the 

following: 

1. Open your video file. 

2. Define the fragments you want to keep in the final movie.  

3. Select the Control -> Obey Sample times menu item.  

4. Continue the splitting process as usual.  

 

See also Control menu, How to set fragments to be kept or cut 

 
 

How to start joining  

 

To start the joining process:  

1. Add the video (audio) files you want to join either using drag'n'drop or by clicking the Add Media File(s) 

button. 



 

 
 

2. If the files have different parameters, you will be notified. 

 

 

 

3. Sort files. 

 

4. Start joining by clicking the Start Joining button or selecting the File->Start Joining menu item. 

 

 

5. Enter the name of the destination file and click Save. The progress bar will appear and show the progress.  

 



 

How to start splitting  

 

To start the trimming process:  

1. Open your video file. 

2. Define the fragments you want to keep in the final movie  

3. Press the Trim key (Ctrl + T) or select Edit -> Start Trimming 

4. If you are asked for a filename, enter a name for the destination file and click Save. The progress bar will 

appear and showing that splitting is in progress.  

Note: selecting the File -> Save Media File As... menu item also starts the trimming process. 

Note: instead of immediate trimming, you can add the task to the batch queue by selecting the Don't start now. 

Add the task to batch queue instead checkbox as shown below: 

 
 

Window element Description Shortcut key 

 

Trim: Start the trimming process Ctrl + T 

 

See also Edit menu, Keyboard shortcuts, Splitting controls, Batch manager 

 
 

 

 



 

 

Technical information  

Video Splitter is based on the SolveigMM Video Editing SDK. 

The AVI Trimmer Component is the freeware demonstration of the SDK. Send any questions about the SolveigMM 

Video Editing SDK to the Solveig Multimedia Technical Support Team at support@solveigmm.com 

SolveigMM Video Splitter includes the following components:  

Component File Name Description 

 

COM \ ActiveX objects 

SolveigMM Video Editing Engine SMM_EditEngine.dll 

COM object for GOP accurate 

AVI, Windows Media video, 

MPEG1 and 2, Windows Media 

audio trimming without 

decoding/encoding. 

SolveigMM ActiveX time line control SMM_OCXSlider.ocx ActiveX time line control 

 

Direct show Trimmer Filters 

SolveigMM Trimmer SMM_Trimmer.ax 

DirectShow filter for AVI, ASF, 

WMV, WMA, MPEG1, 2 audio 

(ISO/IEC 11172-3, ISO/IEC 

13818-3) GOP accurate file 

trimming 

SolveigMM-Elecard MPEG-2 Frame Accuracy Trimmer SMM_MP2FATrimmer.ax 
DirectShow filter for frame 

accurate MPEG-2 Video/Audio 

trimming 

SolveigMM MPEG4 Trimmer SMM_MPEG4TrimmerFA.ax 
DirectShow filter for MPEG4 AVC 

GOP/Frame accurate file 

trimming. 

SolveigMM ASF Trimmer SMM_ASF_Trimmer.ax  
DirectShow filter for frame and 

GOP accurate Windows Media 

Video files trimming. 

SolveigMM MPEG4 Visual Trimmer  SMM_MP4VTrimmerFA.ax 
DirectShow filter for MPEG4 

Visual Video frame accurate 

editng 

SolveigMM VP8 Video Trimmer SMM_VP8TrimmerFA.ax  
DirectShow filter for VP8 video 

frame accurate editing  
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Direct show Multiplexer/Demultiplexer 

SolveigMM ASF Multiplexer SMM_ASFMuxer.ax 

DirectShow filter for the video 

and audio multiplexing into 

Microsoft Advanced Streaming 

Format.  

SolveigMM Wave format Multiplexer SMM_WavMux.ax 
DirectShow filter for the audio 

multiplexing into Wave File 

Format 

SolveigMM MP4 format Multiplexer SMM_MP4Muxer.ax  

Direct show filter for video and 

audio multiplexing into 

QuickTime File Format and 

MPEG-4 

SolveigMM MP4 format Demultiplexer SMM_MP4Demuxer.ax 

Direct show filter for 

demultiplexing QuickTime File 

Format and MPEG-4 Part 14 file 

format. 

SolveigMM Matroska file format Multiplexer SMM_MKVMuxer.ax 
Direct show filter for video and 

audio multiplexing into Matroska 

file format. 

SolveigMM Matroska file format Splitter SMM_MKVSplitter.ax 
Direct show filter for 

demultiplexing Matroska file 

format 

 
Direct show Encoders/Decoders 

SolveigMM Vorbis Audio Decoder  SMM_VorbisDecoder.ax Decoder for Vorbis audio 

SolveigMM VP8 Video Decoder SMM_VP8Decoder.ax  Decoder for VP8 video  

SolveigMM VP8 Video Encoder SMM_VP8Encoder.ax Encoder for VP8 video 

 
Others 

SolveigMM File Writer SMM_FileWriter.ax 

DirectShow filter for writing AVI 

and MPEG audio files. It is used 

to keep A/V synchronization 

when AVI with MPEG VBR audio 

is trimmed 

SolveigMM K Frame Manager  SMM_KFrManager.ax 
DirectShow filter for providing 

the K frame navigation during 

playback 

SolveigMM Media Joiner SMM_MediaJointer.ax 
DirectShow filter file-by-file 

audio/video joining. 

SolveigMM ASF Validator SMM_ASFValidator.dll 
Library for Windows Media Video 

files validation. 



SolveigMM Thumbnails Generation Library SMM_ThumbNail.dll 
Library for generation 

thumbnails from video files. 

SolveigMM Custom Encoder SMM_CustomEncoder.dll 
Library for partial reencoding 

video fragments 

 

Batch file structure  

Video Splitter batch files have the *.xtl, *.jxtl extensions and are based on the DirectShow Editing Services XTL 

format.  

 

Note: All the sections and attributes are case-sensitive and must be in the lower case. The values must be 

enclosed in quotation marks ("").  

 

timeline Element  

 

The timeline element defines the timeline. This element is the root node in an XML file.  

 

Example:  

<timeline>  

</timeline>  

 

Attributes:  

no attributes specified.  

 

Parent/Child Information  

Parent Children 

None, root element. group  

 

group Element  

 

The group element defines a group, the top-level object in a timeline.  

 

Example:  

<group name="....." mode=".....">  

</group>  

 

Attributes:  

Attribute name Possible values Required Description 

name Any string without symbol (") Yes The name attribute specifies the output filename with its path 

mode  trimming, joining, indexation No*  

Specifies the operation performed with the file in the clip. 

 
trimming = the specified file will be trimmed 

joining = the specified files will be joined 

indexation = the specified file will be indexed 

* If this parameter is not present, the default value is trimming.  

Note: "indexation" can be performed only for MPEG-2 files, "joining" can merge only files with the same 

audio/video parameters(file types, video frame width/height, video/audio compression type). 



 

Parent/Child Information  

Parent Children 

timeline  track  

 

track Element  

 

The track element defines a track object (media files).  

 

Example:  

<track video="..." audio="..." obey_sample_times="...">  

</track>  

 

Attributes:  

Attribute name 
Possible 

values 
Required Description 

video any number No 
The video attribute specifies the number of video streams. The 0 

value means the output file contains no video stream*  

audio any number No 
The audio attribute specifies the number of audio streams. The 0 

value means the output file contains no audio stream* 

obey_sample_time 0, 1 No 

The obey_sample_times attribute specifies whether an alternative 

synchronization algorithm should be used:  

 

0 = Do not use obey_sample_time 

1 = Use obey_sample_time  

* In case of joining, it should be set to -1. 

 

Note: By default, if neither video nor audio is specified, both values are 1. If one of the values is present, the 

default value of the missing parameter is 0.  

By default, obey_sample_time equals 0.  

 

Parent/Child Information  

Parent Children 

group  clip  

 

clip Element  

 

The clip specifies the media source.  

 

Example:  

<clip src="..." start="..." stop="..."/>  

 

Attributes:  



Attribute 

name 
Possible values Required Description 

src 
any string without 

symbol (") 
Yes 

The src attribute specifies the path name of the input media 

file 

start HH:MM:SS.mS Yes 
The start attribute specifies the start time of the fragment to 

be saved in the output file. 

stop HH:MM:SS.mS Yes 
The stop attribute specifies stop time of the fragment to be 

saved in the output file. 

 

Note: In case of trimming, the src attributes values of all clip sections must be identical within the track section.  

The start and stop time for joining should be set to 00:00:00:00. It means the whole file will be added to the 

output. 

 

Parent/Child Information  

Parent Children 

track  no 

 

 

Sample batch file 

Trimming  

<timeline>  

<group name="C:\video\result\Noname.avi">  

<track video="1" audio="2" obey_sample_times="0">  

<clip src="C:\video\Progulka.avi" start="00:00:00.00" stop="00:12:32.00"/>  

<clip src="C:\video\Progulka.avi" start="00:32:41.00" stop="00:42:02.00"/>  

<clip src="C:\video\Progulka.avi" start="00:54:09.00" stop="01:08:51.00"/>  

</track>  

</group>  

<group name="C:\video\result\Noname1.avi">  

<track video="0" audio="1" obey_sample_times="1">  

<clip src="C:\video\Microcosmos.avi" start="00:11:48.08" stop="00:20:14.52"/>  

</track>  

</group>  

</timeline>  

Two files will be created as a result:  

1) C:\video\result\Noname.avi - the file will consist of three sequential fragments from 

C:\video\Progulka.avi  

Start Time End Time 

00:00:00.00 00:12:32.00 

00:32:41.00 00:42:02.00 

00:54:09.00 01:08:51.00 

 

The file will contain the video stream and the second of two audio stream.  



2) C:\video\result\Noname1.avi - the file will consist of one audio fragment from C:\video\Microcosmos.avi  

Start Time End Time 

00:11:48.08 00:20:14.52 

 

The file will contain only the audio stream.  

 

Indexation  

<timeline>  

<group name="C:\video\Test.mpg.xtl" mode="indexation">  

<track video="1" audio="1">  

<clip src="C:\video\Test.mpg" start="00:00:00.00" stop="00:00:00.00"/>  

</track>  

</group>  

</timeline>  

As a result, the index file would be created for the corresponding MPEG-2 file specified in the clip  

 

Joining  

<timeline>  

<group name="C:\Test_full.mp3" mode="joining">  

<track video="-1" audio="-1"> 

<clip src="C:\Test_part0.mp3" start="00:00:00.00" stop="00:00:00.00"/><br>  

<clip src="C:\Test_part1.mp3" start="00:00:00.00" stop="00:00:00.00"/><br>  

<clip src="C:\Test_part2.mp3" start="00:00:00.00" stop="00:00:00.00"/><br> 

<clip src="C:\Test_part3.mp3"  start="00:00:00.00" stop="00:00:00.00"/><br> 

</track>  

</group>  

</timeline>  

 

As a result, a file containing all parts specified in each clip in the specified order will be created 
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SolveigMM Batch Splitter console utility 

The SolveigMM Batch Splitter console utility (SMM_BatchSplit.exe) duplicates the SolveigMM Video Splitter 

video/audio trimming functionality in the console mode. It allows you to trim AVI, ASF/WMV/WMA, MPEG-1, 
MPEG-2, MP4, MOV, MKV, AVCHD, MPEG Audio files (See Supported File Formats for more details). The files and 

parameters should be described in the batch file (*.xtl) specified as the input parameter to the utility.  

The batch file specification is described here.  

It can also be produced with SolveigMM Video Splitter Batch Manager  

Usage:  

BatchSplit.exe [-L logfilename] file.xtl  
Parameters:  

-L logfilename: Log filename. By defaultm it is BatchSplit.log. Use the NULL value to disable logging  
file.xtl: Batch file name with its full path.  

Example:  
BatchSplit.exe -L MySplitTaskLog.log "D:\Video\SplitTasks\MySplitTask.xtl"  

See also Sample batch file  
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