Author Topic: Проблема при разрезке.  (Read 11952 times)

Offline VUGLUSKR

  • Users
  • *
  • Posts: 8
    • View Profile
Re: Проблема при разрезке.
« Reply #7 on: March 17, 2010, 08:37:30 AM »
Ясно.
Спасибо за ответы.

Offline Dmitry Vergeles

  • Administrator
  • Users
  • *****
  • Posts: 876
    • View Profile
Re: Проблема при разрезке.
« Reply #6 on: March 16, 2010, 09:11:45 AM »
да планируется, но пока что не на приоритетном месте. т.е через месяца 2-4 может появиться.
Regards,
Dmitry Vergeles
Solveig Multimedia

Offline VUGLUSKR

  • Users
  • *
  • Posts: 8
    • View Profile
Re: Проблема при разрезке.
« Reply #5 on: March 16, 2010, 08:11:23 AM »
Пока для WMV/AVI/ASF файлов только работа по ключевым кадрам. т.е если начало отрезка стоит не на k-frame, то сплиттер будет добирать недостающие кадры от начала гопа, и естли ваш видео материал закодирован с длинными группами кадров ~10 сек (если вы кодируете его сами просто выставляйте GOP короче) то да, будут отсаваться данные вначала отрезков.

Если вы работаете с ACVHD и MPEG-2 такого эффекта не будет, т.к. точность для этих форматом покадровая

Я работаю в основном как раз с форматами WMV/AVI. И описанная проблема мне очень мешает. И хотя SolveigMM Video Splitter мне нравится и во многом устраивает, приходится пользоваться дургой программой, т.к. мне нужна точность нарезки.

Планируется ли в дальнейшем исправить эту проблему для файлов WMV/AVI?

Offline Dmitry Vergeles

  • Administrator
  • Users
  • *****
  • Posts: 876
    • View Profile
Re: Проблема при разрезке.
« Reply #4 on: March 15, 2010, 08:40:14 AM »
Quote
1. Дело в том, что даже если убрать "галки" с пунктов "Slider K-Frame Positioning" и "Markers K-Frame Positioning", проблема остаётся. То бишь есть эта функция (K-Frame Positioning) или нет - не имеет значения.

Да, эти галки лишь позволят вам ставить маркеры на ключевые кадры, т.е. понимать откуда будет осуществляться редактирование.

Quote
2. Значит, эту проблему устранить невозможно? Т.е. при нарезке всегда будут оставаться лишние 3-8 сек. вначале?

Пока для WMV/AVI/ASF файлов только работа по ключевым кадрам. т.е если начало отрезка стоит не на k-frame, то сплиттер будет добирать недостающие кадры от начала гопа, и естли ваш видео материал закодирован с длинными группами кадров ~10 сек (если вы кодируете его сами просто выставляйте GOP короче) то да, будут отсаваться данные вначала отрезков.

Если вы работаете с ACVHD и MPEG-2 такого эффекта не будет, т.к. точность для этих форматом покадровая
Regards,
Dmitry Vergeles
Solveig Multimedia

Offline VUGLUSKR

  • Users
  • *
  • Posts: 8
    • View Profile
Re: Проблема при разрезке.
« Reply #3 on: March 15, 2010, 12:27:48 AM »
1. Дело в том, что даже если убрать "галки" с пунктов "Slider K-Frame Positioning" и "Markers K-Frame Positioning", проблема остаётся. То бишь есть эта функция (K-Frame Positioning) или нет - не имеет значения.
2. Значит, эту проблему устранить невозможно? Т.е. при нарезке всегда будут оставаться лишние 3-8 сек. вначале?

Offline Dmitry Vergeles

  • Administrator
  • Users
  • *****
  • Posts: 876
    • View Profile
Re: Проблема при разрезке.
« Reply #2 on: March 14, 2010, 06:32:27 PM »
Здравстуйте VUGLUSKR,

Описанное Вами поведение абсолютно верно, т.к видео сплиттер работает с точностью до ключевого кадра

Выглядит это примерно так

Видео последовательность обычно состостоит из так называемой группы кадров (GOP - groups of pictures ) которая начинается с ключевого кадра, как показано на рисунке.




Ключевые карды закодированы независимо и ссылаются на другие видео фреймы. Т.е могут быть декодированы без какой либо дополнительной инфрмации. Чтобы обеспечить видео редактирование без потери качества и в быстром режиме сплиттер режет AVI/ASF/WMV видео по ключевым кадрам.

Чтобы видеть те кадры по которым будет происходить редактирование, сделаны функции позиционирование по ключевым кадрам:


Несмотря на вышеописанное, спиттер работает с точностью до кадра для MPEG-2 и AVCHD файлов, перекодируя только часть кадров в начале и конце выделенного  фрагмента, оставляя 90 % исходных данных не тронутыми.
« Last Edit: March 14, 2010, 06:34:03 PM by Dmitry Vergeles »
Regards,
Dmitry Vergeles
Solveig Multimedia

Offline VUGLUSKR

  • Users
  • *
  • Posts: 8
    • View Profile
Проблема при разрезке.
« Reply #1 on: March 13, 2010, 01:00:01 PM »
Во всех версиях такая проблема:
При нарезке программа захватывает несколько дополнительных секунд вначале разрезаемой сцены/ролика.
То есть. Например, я хочу разрезать 10-тиминутное видео в определённом месте. Ставлю маркер на 00:05:20:00 (5 мин. 20 сек.). В итоге вторая часть разрезанного видео при просмотре начнётся не с того момента, на котором я поставил маркер, а на 3-8 сек. раньше.
И не имеет значения, сколько маркеров ставить. Во всех случаях при разрезке итоговые ролики получаются с лишними 3-8 секундами вначале. А если я хочу просто вырезать из любого фильма первые 3-8 сек., то это сделать невозможно по той же причине. Итоговый ролик получается такой же, начало не вырезается.
При этом концы фильмов обрезаются правильно, то есть ровно в том месте, где был установлен маркер.
Из-за чего это? можно ли это как-то исправить?
« Last Edit: March 13, 2010, 01:01:39 PM by VUGLUSKR »