Author Topic: Проблема с сохранением MPEG TS info или PID  (Read 1162 times)

Offline Maxim.Sakhankov

  • Users
  • *
  • Posts: 157
    • View Profile
Re: Проблема с сохранением MPEG TS info или PID
« Reply #5 on: February 28, 2018, 06:11:04 PM »
Здравствуйте misha1961,
Описанное вами поведение не удается воспроизвести на наших файлах. Если нет возможности прислать исходный файл, пожалуйста, отрежьте небольшой фрагмент, на котором не будет распознаваться битрейт, и пришлите его.  Также, можете выложить mediainfo исходного и отрезанного файла.
Еще раз повторюсь, что галка включает сохранение данных TS-потока и не влияет на битрейт, поскольку битрейт не является характеристикой TS-потока, он является характеристикой элементарного видео/аудио потока и является обязательным для mpeg2 видео, в то время как в AVC/H264 видео он не является обязательным и может отсутствовать. В 6 версии Video Splitter было добавлено копирование группы параметров, в том числе и битрейта, если они присутствовали в исходном AVC видео.

Offline misha1961

  • Users
  • *
  • Posts: 3
    • View Profile
Re: Проблема с сохранением MPEG TS info или PID
« Reply #4 on: February 27, 2018, 10:23:24 PM »
124 просмотра и ни одного коммента!Ни у кого не было такой проблемы?Уважаемый модератор,а вы что молчите?

Offline misha1961

  • Users
  • *
  • Posts: 3
    • View Profile
Re: Проблема с сохранением MPEG TS info или PID
« Reply #3 on: February 21, 2018, 05:18:29 PM »
День добрый!Именно эту версию я использую.Файл может быть любой,я режу и большие файлы по 15-18 гб, проблем не было.Единственное частенько программа зависает намертво,но я почитал посты,не только у меня такая проблема,я смирился.в целом программа отличная,номер один я бы сказал!В какой момент появилась эта проблема не знаю,пересмотрел последние обрезанные файлы,все без битрейта,хотя галка стоит.На воспроизведение не влияет,просто не понятно почему не сохраняется инфа.как я уже говорил,раньше было всё ок,а теперь даже на семерке такая же ерунда.как я писал,семерка вообще стоит на другом харде!хотелось бы докопаться до причины.версии медиаинфо пробовал тоже разные,дело не в ней

Offline Maxim.Sakhankov

  • Users
  • *
  • Posts: 157
    • View Profile
Re: Проблема с сохранением MPEG TS info или PID
« Reply #2 on: February 21, 2018, 03:15:45 PM »
Здравствуйте misha1961,
Опция сохранения ts параметров доступна только в бизнес-редакции, начиная с версии 5.2. При установленной галке сохраняются только идентификаторы в TS потоке (TS PID , PES ID), параметры видео/аудио потоков могут изменяться.
Пожалуйста, попробуйте использовать последнюю из версий 5.2 или текущую версию (релизная, бета). Если проблема останется, то, пожалуйста пришлите нам ваш исходный файл.
Кроме того, хотелось бы уточнить, влияет ли описанная вами проблема (отображение битрейта) на воспроизведение полученного файла, и если влияет, то как именно?

Offline misha1961

  • Users
  • *
  • Posts: 3
    • View Profile
Проблема с сохранением MPEG TS info или PID
« Reply #1 on: February 21, 2018, 04:16:14 AM »
День добрый!Появилась такая проблема,после резки видеофайла не сохраняется mpeg ts info,галочка стоит,пробовал на 5 версии и на 4,Windows XP,Windows 7 системы стоят на разных дисках,а проблема одинаковая.до резки Mediaifo показывает видео и аудио битрейт,после резки битрейт пропадает.пользуюсь программой давно,было всё ок,а сейчас вот такая ерунда.даже не знаю,куда копать.