Author Topic: 7.0 crash with error SMM_OCXSlider.ocx Not related to device  (Read 37 times)

Offline Marty

  • Users
  • *
  • Posts: 33
    • View Profile
7.0 crash with error SMM_OCXSlider.ocx Not related to device
« Reply #1 on: December 09, 2018, 01:38:28 AM »
Hello,

This is interesting. Is it faster to write to the support instead of here ?

i shared some messages in the past with the support about the crash of this "SMM_OCXSlider.ocx" while using the solveig software. at this time, support told me it was not SMF which had an error but my device driver, a counter design shuttle expres, who is a jog and some buttons who just send keys shortcut.

well, the crash are continuing with the 7.0 of course, but with an another device, from an another brand. I use Bome Midi Translator with a Steinberg CMC-Ai, who does the same. there is a Jog to move the slider faster in the timeline. why i would do that ? because i'm a disabled  person with hands issues, so i use these kind of device to lower the use of my hands and pains because i can't use a mouse or something like that in a repetitive way.

what both devices does ? isomething very simple... they just send Keyboard shortcut !

so, to move the slider in the timeline, a shortcut is used, it's just using the "move to the next K frame" shortcut. so when i turn my jog, it's sending this "right or left" shortcut keys to the software. nothing else. it's working perfectly, EXCEPT that "sometimes", the software crashes.. most of the time, it crash near or when the slider moved on the part where 2 videos files are joined. (i can make a picture to explain it better).

now, these devices are from different brand, work differently, don't crash in other software (cubase, Vegas Pro etc..)
the counter design shuttle express device use his own software through his own driver.
but the steinberg CMC Ai is just sending Midi command ! he's not even seen by SMF, the software which translate the midi command to keyboard shortcut (under windows 10) is Bome Midi translator, a very well known software in this field.

So i can understand that in the first place, it could be a problem with my device, but here it's different.

it's maybe a bug, or maybe your software can't handle too much shortcut sent one after one, i don't know... any help would be much appreciated. your software is very helpful, i appreciate a lot the "last backup" feature which is saved so often that when it crash, i can restart the edit from where it crashed, (maybe it's the issue ? it crashes when the backup is saved ?), but i admit as well that it's an issue which put on Nerves a LOT . !

Thanks for any help !
« Last Edit: December 09, 2018, 01:40:57 AM by Marty »