Author Topic: 7.0 not working with external srt subtitle and generate empty srt file  (Read 11684 times)
  • Users
  • *
  • Posts: 69
    • View Profile
« Reply #16 on: December 30, 2021, 03:51:14 PM »
Hi Marty,

thank you for keep pinging us ) We just missed it at some point, but supporting of subtitles is important.
Keep an eye on updates, we should fix it somewhere in Jan.
Regards,
Dmitry

Thanks !

  • Administrator
  • Users
  • *****
  • Posts: 875
    • View Profile
« Reply #15 on: December 29, 2021, 09:58:19 PM »
Hi Marty,

thank you for keep pinging us ) We just missed it at some point, but supporting of subtitles is important.
Keep an eye on updates, we should fix it somewhere in Jan.
Regards,
Dmitry
Regards,
Dmitry Vergeles
Solveig Multimedia

  • Users
  • *
  • Posts: 69
    • View Profile
« Reply #14 on: December 24, 2021, 11:35:13 PM »
Hi Marty,

Sorry you experience these issues. Do we talk about a bug or some missed feature?
We will re-check it with our team and let you know whats going on.

We're talking about a 3 years old reported bug using SRT subtitle when they are used with a H264 Mp4/Mkv video. i sent numerous files and report here or in private to the support about it. they could reproduce the issue and was "telling here when a fix would be done", but it has never been done.

On a lot of video files I use with your software, I have a Mp4 video file (H264) + an external SRT, or a MKV with external or internal SRT file.

what's happening ?

by importing "one video" only, and after put markers and launch the cut processing, at some points, the processing stop. it's freeze totally, only way to continue is to click on cancel.

only way to have the whole video cut is to open the stream selector (right click on the video screen preview) select stream, and uncheck the subtitle track. then I relaunch the processing and everything is working, but we loose the subtitle track, and must redo all the subtitles sync and do the cut with an external software.

when doing it in batch using several videos, it's worst. the subtitles are out of sync. So i don't do any batch process when using subtitles.

They are other bugs... like sometimes a video refuse to process after some marks (with or without subtitle), cancel do nothing, and only way is to force the close of the video. sometimes the software crash. when you cut a 1 hour or 2 hours video and you lost all the work, after a while it can be a "bit" boring.

I'm starting to do my cut again in a Pro video software (Vegas Pro 19) when i don't need subtitle , because after a while, it's very very boring. your software work well, fast, but ... loosing hours of work can be a lot of boring, especially when the "backup" save didn't work and we must redo everything.


January 2019 !!

" Maxim.Sakhankov
Administrator

Re: 7.0 not working with external srt subtitle and generate empty srt file
« Reply #5 on: January 24, 2019, 03:52:07 PM »
Quote
Hello Marty,
After checking your files I think I found 2 different issues:
1) When you load a project with an external subtitles or restore from a backup copy of the project after a crash, the external subtitles stream is disabled for trimming.
2) When you load more then 1 file to the timeline and save the output file - only subtitles from the first file are saved.

I'll post here when the fix is available."
« Last Edit: December 24, 2021, 11:42:15 PM by Marty »

  • Administrator
  • Users
  • *****
  • Posts: 875
    • View Profile
« Reply #13 on: December 24, 2021, 11:05:10 PM »
Hi Marty,

Sorry you experience these issues. Do we talk about a bug or some missed feature?
We will re-check it with our team and let you know whats going on.
Regards,
Dmitry Vergeles
Solveig Multimedia

  • Users
  • *
  • Posts: 69
    • View Profile
« Reply #12 on: December 24, 2021, 10:13:27 PM »
Hi Marty,
All are alive, we were just busy with other things.

ok, i understand, but hope the subtitles fix will appears at some points... 3 years is a long time for a fix lol... Your software work great, but this issue make it want to explode the screen and the computer each time it happens... work ok during few cuts, and then freeze, and only way to have to process the video is to remove the subitile, and we must then redo the whole sync :(. It forbidd to do any serious thing..

  • Administrator
  • Users
  • *****
  • Posts: 875
    • View Profile
« Reply #11 on: December 24, 2021, 09:57:27 PM »
Hi Marty,
All are alive, we were just busy with other things.
Regards,
Dmitry Vergeles
Solveig Multimedia

  • Users
  • *
  • Posts: 69
    • View Profile
« Reply #10 on: December 03, 2021, 07:43:37 PM »
Hello,

Sorry that you have such experience with work with our product.
As soon as there will be any fixes with editing files with srt subtitles, we will post them here.

the last time someone from Solveig told this was in January 2019... is the company dead ? the software dead ? Thanks for "any" answer.

"Maxim.Sakhankov
Administrator
Re: 7.0 not working with external srt subtitle and generate empty srt file
« Reply #5 on: January 24, 2019, 03:52:07 PM »

Hello Marty, After checking your files I think I found 2 different issues:
(...)
I'll post here when the fix is available."

  • Administrator
  • Users
  • *****
  • Posts: 1081
    • View Profile
« Reply #9 on: December 03, 2021, 03:19:45 PM »
Hello,

Sorry that you have such experience with work with our product.
As soon as there will be any fixes with editing files with srt subtitles, we will post them here.
Regards,
Olga Krovyakova
Solveig Multimedia

  • Users
  • *
  • Posts: 1
    • View Profile
« Reply #8 on: December 01, 2021, 10:09:08 PM »
Hi, I have a similar issue, and in principle, after upgrading to 7.0, everything works well. For me, the solution was to simply update to the latest version.
« Last Edit: December 27, 2021, 02:44:40 PM by Maxim.Sakhankov »

  • Users
  • *
  • Posts: 69
    • View Profile
« Reply #7 on: September 10, 2021, 03:07:52 AM »
I'll try to reproduce this issue. Does it mean that it is only specific to the MP4 videos?

certainly it happens with Mkv too. it's very annoying. there are still lot of bugs very annoying not fixed, and it was reported in 2019.
i'm on the 64 bits version actually and it's... :( ..

- external subtitles most of the time block at some point the cut. sometimes at the first cut, sometimes in the end like after 6 cut, the 6th one block and don't finish. only way is to hit cancel, right click on the screen, and unselect (with the cizzor) the subtitle track. and then the file can be cut normally, without the subttiles. when it's happening on the frst cut, it's very annoying. when you spend one hour to work on a 1 hour movie and do a lot of cut, sometimes one hundred, and that in the midle, or at the end or even at the beginning, the issue happens and stop processing.
no other choice to stop it, save the project. remove the licence of the 64 bits version, and try with the 32 bits one as sometimes, the bug doen't happen in one of the version (lol).

 it's out of question, to bypass a bug which must be fixed since 3 years, that i buy a second licence to have a 32 and 64 bits version at the same time. it's just ridiculous... Can't tell i'm happy, i like this software because it work very well most of the time, intuitive and do what it tell, but some bugs are very very annoying, this one is one of the worst, witht he empty srt file.

- an another one is the not in sync subtitle anymore when we cut several videos in batch import. only way is to edit/cut one video at a time, and not using the batch.

- as well i'm not sure if it's related to a driver issue, but what i own is one of the jog the most well known and used. i own a Shuttle Xpress from contour design, and when we import several videos to cut in batch import, at the point where 2 videos are reunited, if we cut close to this point, the software crash. lol. like end of video 1 and beginning of video 2. if i want to cut on the first frame it crash. so i cut some frames after the beginning and some before the end lol.. so when it crash, sometimes the auto save option work, and great, but sometimes, there is no autosave, and all the cuts are lost.
« Last Edit: September 13, 2021, 12:42:33 PM by Maxim.Sakhankov »

  • Users
  • *
  • Posts: 1
    • View Profile
« Reply #6 on: September 10, 2021, 02:54:19 AM »
I'll try to reproduce this issue. Does it mean that it is only specific to the MP4 videos?
« Last Edit: September 13, 2021, 12:42:20 PM by Maxim.Sakhankov »

  • Administrator
  • Users
  • *****
  • Posts: 300
    • View Profile
« Reply #5 on: January 24, 2019, 03:52:07 PM »
Hello Marty,
After checking your files I think I found 2 different issues:
1) When you load a project with an external subtitles or restore from a backup copy of the project after a crash, the external subtitles stream is disabled for trimming.
2) When you load more then 1 file to the timeline and save the output file - only subtitles from the first file are saved.

I'll post here when the fix is available.

  • Users
  • *
  • Posts: 69
    • View Profile
« Reply #4 on: December 23, 2018, 08:22:12 AM »
Hello Marty,

I'll try to reproduce this issue. Does it mean that it is only specific to the MP4 videos?

Hello i could reproduce the subtitle empty bug and the runtime error as well. i just sent you a private message on the forum with Two dropbox Zip files with the video and subtitle in it, and the project as well which made both error happened ! Thanks ! Hope it will Help !
But to answer you, as the error happened with an MKV file, so not, it's not mp4 Specific !

  • Administrator
  • Users
  • *****
  • Posts: 300
    • View Profile
« Reply #3 on: December 20, 2018, 06:34:57 PM »
Hello Marty,

I'll try to reproduce this issue. Does it mean that it is only specific to the MP4 videos?

  • Users
  • *
  • Posts: 69
    • View Profile
« Reply #2 on: December 09, 2018, 08:05:22 AM »
Ok i found the problem... hope it will fixed quickly.

When the software crash (around 20 times tonight on a 4 hours session work :( ), often, in the stream selector, the subtitle track is de-activated...
we must click again on the scissor to have them again in the rendered file. if not a MKV file is generated with no subtitle track, or in case of an external subtitle track, a subtitle file is not gererated.