Author Topic: Split Subtitles are attached immediately after the last line  (Read 14859 times)

Offline Olga Krovyakova

  • Users
  • *
  • Posts: 1065
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #12 on: December 31, 2020, 03:07:55 PM »
Hello all,

We have fixed in the version 7.6 some crashes and it has other fixes related to subtitles.
The request from this topic is regrettably not yet fixed, but we hope to have the update in the near future.
Thank you for your patience!

Have a happy New Year 2021!
Regards,
Olga Krovyakova
Solveig Multimedia

Offline Marty

  • Users
  • *
  • Posts: 62
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #11 on: December 29, 2020, 04:19:57 AM »
Hello,

Do you know when that update will be ready? SolveigMultimedia is great, but that subtitle bug is the only part that's problematic for me.

it's on their "to do" list since 2 years, i'm sure it will be fixed tomorrow, ahah lol... :( (waiting for that fix too, since 2 years :( )

Offline Olga Krovyakova

  • Users
  • *
  • Posts: 1065
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #10 on: November 13, 2020, 05:40:55 PM »
Hello,

Please excuse for possible inconveniences.
When the update with the fixed bug will be ready, we will post it here.
Regards,
Olga Krovyakova
Solveig Multimedia

Offline Marty

  • Users
  • *
  • Posts: 62
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #9 on: November 12, 2020, 03:48:55 AM »
Still having same issue on v7.4, it happens with all files with external SRT subs. Fortunately, it does not occur for individual fragments so I can at least merge them using mkvtoolnix.

same as you, so i edit in one fragment at a time like you... i only use the several import files to cut, for stuff without subtitles. Very frustrating but.. it's on their "to do list", the magic word...

Offline skizlock

  • Users
  • *
  • Posts: 10
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #8 on: November 12, 2020, 02:54:20 AM »
Still having same issue on v7.4, it happens with all files with external SRT subs. Fortunately, it does not occur for individual fragments so I can at least merge them using mkvtoolnix.

Offline Marty

  • Users
  • *
  • Posts: 62
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #7 on: April 15, 2019, 07:05:04 PM »
I got it. As I said earlier, I reproduced a similar behavior, so, when the fix is available, I'll post here.

hi any news about an update ? it's now 2 months, and we have no news, except the developpement of a cloud thing... i'm happy for the ones who will enjoy that, but our software is still buggy ;) any date of a possible fix for this issue ? Thanks :) !

Offline Maxim.Sakhankov

  • Users
  • *
  • Posts: 293
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #6 on: February 15, 2019, 03:18:37 PM »
I got it. As I said earlier, I reproduced a similar behavior, so, when the fix is available, I'll post here.

Offline skizlock

  • Users
  • *
  • Posts: 10
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #5 on: February 14, 2019, 05:24:48 PM »
I don't have the source to help out but i don't think its that hard to replicate, considering it happens with all srt external subtitles. I only tested with mkv and mp4, both produced the same results. Perhaps the next time, I am given a similar project that I will post some samples.

Offline Marty

  • Users
  • *
  • Posts: 62
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #4 on: January 29, 2019, 05:52:17 AM »
Hello skizlock,

I reproduced a similar behavior: when saving multiple fragments from a source file the timing of the second and other fragment's subtitles is shifted a little, but it does not start right after the last line of the first fragment's subtitle. I suppose that the problem is the same, but to make sure, could you please send me your files and a trimming project? You can send files to our technical support (support(at)solveigmm.com) or to me directly via a forum's private message. Please do include a reference to this topic in your e-mail.

Maxim, i confirm you that i have the same issue than Skizlock, that's also one of the bug i reported there earlier, by cutting several files at the same time, the external subtitles file generated have a delay and i must fix them all the time with an another software. It's happening with almost any mp4 with ext subrip .srt file.

Offline Maxim.Sakhankov

  • Users
  • *
  • Posts: 293
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #3 on: January 24, 2019, 03:06:51 PM »
Hello skizlock,

I reproduced a similar behavior: when saving multiple fragments from a source file the timing of the second and other fragment's subtitles is shifted a little, but it does not start right after the last line of the first fragment's subtitle. I suppose that the problem is the same, but to make sure, could you please send me your files and a trimming project? You can send files to our technical support (support(at)solveigmm.com) or to me directly via a forum's private message. Please do include a reference to this topic in your e-mail.

Offline skizlock

  • Users
  • *
  • Posts: 10
    • View Profile
Re: Split Subtitles are attached immediately after the last line
« Reply #2 on: January 01, 2019, 02:04:18 AM »
I installed v7 today so didn't notice but it is doing this always now. I have to re-sync each and every fragment which does not end with an overlapping subtitle.

Offline skizlock

  • Users
  • *
  • Posts: 10
    • View Profile
Split Subtitles are attached immediately after the last line
« Reply #1 on: January 01, 2019, 01:17:52 AM »
I am facing this issue consistently with external srt subtitles since a few months now. The audio/video streams are correctly cut and merged but subtitles always have this issue. This happens to random fragments in almost every mp4 file I split.

- For example, let's say there are two fragments A and B.
- The last subtitle entry of A ends sometime before the end of the audio/video streams, lets say 5 seconds before.
- When B gets merged, its subtitles start immediately after the last line of subtitle of A.
- The 5 seconds of no subtitles is skipped completely.

To resolve this, I have to use another program to resync the subtitles. I had thought that you would have fixed it with the new version but alas, I was hoping too much. v7 doesn't even select the external subtitles for splitting by default anymore as well...
« Last Edit: January 01, 2019, 01:52:36 AM by skizlock »