Author Topic: Various issues  (Read 11777 times)
  • Administrator
  • Users
  • *****
  • Posts: 294
    • View Profile
« Reply #6 on: November 12, 2018, 03:48:39 PM »
Thank you for the report. I'll try to find similar file to check the Video Splitter behavior.

  • Users
  • *
  • Posts: 6
    • View Profile
« Reply #5 on: November 10, 2018, 04:42:49 AM »
It would take me hours to upload a several hundred MB file, and that's assuming my crappy internet didn't drop out in the middle causing me to have to start over. Also, as I said, it's not the file, because I tried multiple files, all with the same problem, while other editors don't have an issue with them. They're mkv files, muxed from Blu-rays. I tried a 525MB mkv that's encoded vs muxed, and it was fine, so maybe it's an issue with high bitrate or a combination between that and large file size, since the smaller file I tried was high bitrate (Blu-ray) but worked. And I don't know if it will actually help since, again, it's not just one file, but here's the info for the one I originally was trying to edit:

Unique ID                                : 230685890391243286833172657749190981099 (0xAD8C7C850D513918A47D0E0BEE6335EB)
Complete name                            : S:\filename.mkv
Format                                   : Matroska
Format version                           : Version 4
File size                                : 22.0 GiB
Duration                                 : 2 h 20 min
Overall bit rate mode                    : Variable
Overall bit rate                         : 22.5 Mb/s
Encoded date                             : UTC 2016-04-23 15:53:23
Writing application                      : mkvmerge v9.0.1 ('Obstacles') 64bit
Writing library                          : libebml v1.3.3 + libmatroska v1.4.4

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.1
Format settings                          : CABAC / 4 Ref Frames
Format settings, CABAC                   : Yes
Format settings, RefFrames               : 4 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 2 h 20 min
Bit rate mode                            : Variable
Bit rate                                 : 18.4 Mb/s
Maximum bit rate                         : 32.0 Mb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (23976/1000) FPS
Original frame rate                      : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.370
Stream size                              : 18.0 GiB (82%)
Language                                 : English
Default                                  : Yes
Forced                                   : No
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

ID                                       : 2
Format                                   : DTS XLL
Format/Info                              : Digital Theater Systems
Commercial name                          : DTS-HD Master Audio
Codec ID                                 : A_DTS
Duration                                 : 2 h 20 min
Bit rate mode                            : Variable
Bit rate                                 : 4 087 kb/s
Channel(s)                               : 6 channels
Channel layout                           : C L R Ls Rs LFE
Sampling rate                            : 48.0 kHz
Frame rate                               : 93.750 FPS (512 SPF)
Bit depth                                : 24 bits
Compression mode                         : Lossless
Stream size                              : 4.01 GiB (18%)
Language                                 : English
Default                                  : Yes
Forced                                   : No

ID                                       : 3
Format                                   : PGS
Muxing mode                              : zlib
Codec ID                                 : S_HDMV/PGS
Codec ID/Info                            : Picture based subtitle format used on BDs/HD-DVDs
Duration                                 : 2 h 18 min
Bit rate                                 : 10.9 kb/s
Count of elements                        : 3297
Stream size                              : 10.8 MiB (0%)
Language                                 : English
Default                                  : No
Forced                                   : No

  • Administrator
  • Users
  • *****
  • Posts: 294
    • View Profile
« Reply #4 on: November 09, 2018, 03:47:02 PM »
If it is possible to get the file by any other way, please let me know (either by private message or by a message to the support), because we need to have a file to reproduce the described behavior. Also, please describe the type of file you're trying to open. The best would be to have a report from MediaInfo tool.

You can change the time format in a "View"-"Time Format" menu or right-clicking the time edit control.

  • Users
  • *
  • Posts: 6
    • View Profile
« Reply #3 on: November 08, 2018, 11:06:23 PM »
1,2) The file is 22GB, so uploading it isn't going to happen. But it's not the file, since every other video editor I've loaded the file into has handled it just fine, and I tried a couple other files and they did the same thing. Thinking maybe it was struggling with the file due to its size, I tried a smaller one (~600MB), which was slightly better, but not much. It still went unresponsive when trying to edit the time or do other things, it just didn't stay in that state as long (with the larger file, I eventually just killed it after waiting for a few minutes). But once it became responsive again, it would go unresponsive again within a few seconds, and this cycle just kept repeating. So there's clearly something wrong with the software. I then loaded a very small (~130MB) file, and that one seems to work ok.
3-4) As I said, HH:MM:SS.MS is the most common format used, and so this software should support it. This could be done in one of three ways: have it automatically replace the period with a comma when pasting it in, have a separate field for each format, or have it be an option that the user can set which format to use. Also, I don't see how to use ms instead of frame, as it won't allow me to change the semicolon to a comma. And if I type 22 in the seconds place then type a 2 (for the first place after the semicolon), it randomly changes it to 23;17. If I try to change the 3 to a 2, it changes it to 23;14. And so on. Very frustrating.
5) No. I'm talking about if I set a marker, then move it, sometimes it will just vanish, sometimes apparently clearing the selection, sometimes selecting everything. I think what's happening is it's jumping to the beginning, so if it's a start marker, this makes it so everything is selected, and if it's an end marker, it makes it so nothing is.

Also, something seems to have just happened with this website. It was working fine when I first checked your message yesterday, but then when I went to reply it "broke," requiring me to allow mixed content for it to load properly. I've never had to do that before for this site, but since yesterday it's been necessary.

  • Administrator
  • Users
  • *****
  • Posts: 294
    • View Profile
« Reply #2 on: November 07, 2018, 02:25:11 PM »
Hello vertigo,
Thank you for the report.
Please find below some comments:
1, 2) The file loading time and freezes when working with the file may depend on the file itself. Could you please send that file to our technical support with the reference to the current thread. You can use any file sharing services, like Dropbox or Google Drive. To make sure that the file is unchanged, it is recommended to pack the file into a zip-archive.
3) Copying and pasting works only with the specifically formatted values. Video Splitter supports 2 time formats:
 - hh:mm:ss;FRAME - where FRAME is a number of the frame in current second (takes 2 places). The value is separated by the semicolon.
 - hh:mm:ss,MS - where MS is a value of milliseconds (takes 3 places). The value is separated by the comma.
4) By default the time value is represented in hh:mm:ss;FRAME format. See #3 above
5) I suppose that "disappearing" in this case is a collapsing feature - when you work in "Cut" mode and you set a start and a stop markers for the interval, the interval collapses automatically. You can expand it back by double clicking the collapsed marker. You can also disable this feature from the preferences: "View" - "Collapse intervals marked as cut out".

As for the others - we'll check them and try to fix in future releases.

  • Users
  • *
  • Posts: 6
    • View Profile
« Reply #1 on: October 25, 2018, 01:48:11 AM »
I bought this a while ago, and have only used it once so far, and I'm really starting to regret the purchase. This software is currently unusable, and even when it did work, it was a bit problematic. Here's my issues with it:

  • It's slow. Loading a file (image strip at bottom) takes significantly longer than in other programs, and until it's done it's basically unusable.
  • It's unstable. It constantly stops responding for several minutes at a time. For example, every time I try to type into the time fields to move to a specific time, it stops responding. And as if that's not bad enough, the time isn't even changed once it comes back. It also freezes and becomes unresponsive (though doesn't go white like when typing in the time field) when I try to play the video. It also stopped responding when changing categories in preferences (specifically, when accessing "Smart Mode Settings"). It also stopped responding after pressing the previous K-frame button, which also jumped from 11:30 to the beginning of the video, so clearly that doesn't work right, either.
  • I can't paste into the time fields. I don't know if it's because the format is different (I'm trying to paste in the HH:MM:SS.milliseconds format, which is the commonly used (and basically standard) format, whereas this uses a semicolon between seconds and milliseconds), but a) it should use the common format if that's the problem, and b) it should be able to work around that.
  • Milliseconds only go out two places (hundredths) instead of three (thousandths) like other programs.
  • The time markers keep jumping around or disappearing after I place them.
  • The menu bar and menus are tinted so they're a medium-dark gray with black lettering, making their visibility less than ideal. I shouldn't even have to point this one out, and I really just can't understand how anyone thought that was anything other than a terrible idea.
  • Scrolling with the scroll wheel in Preferences > Output File Settings, View, and Control is very slow, only scrolling a few lines at a time. Yes, I can just drag the scroll bar, but I shouldn't have to. This is especially odd since the scrolling works fine in Hotkey Settings and Smart Mode Settings.
  • There's no way to cancel changes in preferences. Are you kidding me? This is one of the most basic features of any program. Not only that, but to make matters worse, escape closes the preferences box and SAVES the changes, meaning possibly unwanted changes will be saved if it's pressed accidentally or if the user presses it thinking, as any logical person would, that it must be how you cancel changes, since there's no cancel button.
  • Probably more, but it's been a while since I used it, so I don't remember, and since it won't work at all now I can't use it to figure any other issues out.

I bought this because it was a good price for a basic, but seemingly capable editor, but instead I see it's a buggy mess with even the most basic of interface elements not done properly. Maybe these issues can be resolved, but unless it happens very soon, which seems rather unlikely, it seems I'll have to find another editor, which will mean the money spent on this one will be a waste.

Edit: Forgot to mention this is on Win10 x64 Pro with an i7-7820x, 64GB RAM, 960 EVO, and GTX 770, so hardware is not the issue.
« Last Edit: October 27, 2018, 02:37:23 PM by vertigo »