Author Topic: Video rarely shown after loading media files for edit  (Read 5707 times)
  • Administrator
  • Users
  • *****
  • Posts: 1177
    • View Profile
« Reply #2 on: March 21, 2022, 05:45:35 PM »
Hello Ghred1147,

Thank you for your post.
Firstly, I would recommend to use the 64-bit version of Video Splitter available here:

Home Edition, 64-bit version

Business Edition, 64-bit version

If you already use this version, please try to set another video renderer in Tools / Preferences / Playback settings - see screenshot at the link please Try different options here.

If this will not help, then could you please send us the original input file that you open in Video Splitter? You can upload it to any file sharing service, e.g. Google drive (
Olga Krovyakova
Solveig Multimedia

  • Users
  • *
  • Posts: 4
    • View Profile
« Reply #1 on: March 18, 2022, 10:56:14 PM »
I'm sure I'm doing something wrong, especially since I'm unfamiliar with v7.6.2, but no matter what I try, I can't find a reliable way to see the video content of the file I want to edit. Even though I use the exact same vid, sometimes I can see the video, but usually I cannot. However, I can hear the audio just fine. And I can see the video in the timeline area.

Here's what I've tried (along with other variants): I drag and drop any video file onto the "Open or drag files for editing" area (I primarily use .mkv format, but I see the same problem with .mp4).  I see no error message, but when I press the Play button, I hear the correct audio, but I rarely does it show any video. I cannot detect any pattern as to when the Media Splitter will display the video or not. It seems random.

My goal in using Video Splitter Home is to cut edit videos with .ass subtitles merged into the file to be edited using MKVToolNix GUI. But I've also tried it without subtitles yet I see the same random problem.

Perhaps there's a codec issue? I am confused by the list of codecs and their priorities in the list that the Media Splitter shows. Can someone please help me out?

I'm running 64-bit Windows 10 Pro on a desktop machine.