Author Topic: Issue with ingame recording  (Read 8579 times)

Offline Olga Krovyakova

  • Users
  • *
  • Posts: 976
    • View Profile
Re: Issue with ingame recording
« Reply #7 on: July 19, 2011, 06:07:28 PM »
Hello Gamecard,

Thank you for your question.

Go into the Catalyst Control Center (right click on your desktop) ->"3D" -> "All settings" . Then on "Wait for vertical refresh" choose the performance setting which is "Always off". If you dont have the Catalyst control center download it from ATI. Some games allow you to turn vsync off and on in thier graphics options too.

For more detailes please visit this page:

http://www.cscenter.pl/en/baza_poradnikow_do_counter_strike_1_6/52730-disable_vertical_sync_on_ati_cards.html
« Last Edit: July 19, 2011, 06:17:53 PM by Olga Krovyakova »
Regards,
Olga Krovyakova
Solveig Multimedia

Offline Gamecard

  • Users
  • *
  • Posts: 7
    • View Profile
Re: Issue with ingame recording
« Reply #6 on: July 18, 2011, 03:35:15 AM »
And with ATI ?....

Quote
Try to disable vertical synchronization on your PC.

This is the most trouble-free method of gaining the fastest possible performance. This is the simplest solution, and on monitors which have a standard 60Hz refresh rate, or for games in which your framerate is not consistently above 60FPS, this appears to be the best solution. You may notice some tearing, but this will generally be minimal if your FPS remains well below your refresh rate. Remember though that whenever VSync is disabled the graphics card and monitor are not strictly in sync, and tearing (however minor) may occur at any time.

Many games have the option to disable v-sync. Also, if you go to Start / Control Panel / Display Properties / Settings / Advanced there will be an option to disable V-Sync using your video card's driver software.

Assuming you are using Nvidia drivers, then, right click anywhere on the desktop.

 1) Choose properties.

 2) Go to settings.

 3) Choose advanced.

 4) Go to Open GL settings.

 5) Go to Vertical Sync.

 6) Select "disable"  or 'Switch off" Vsync.

 7) Apply


Please let me know if it will help you.
« Last Edit: July 18, 2011, 03:42:05 AM by Gamecard »

Offline Thanatos00

  • Users
  • *
  • Posts: 3
    • View Profile
Re: Issue with ingame recording
« Reply #5 on: May 10, 2011, 10:26:53 PM »
Hi Olga,

Your welcome ! :)

No problem, I will try to look at this topic occasionally.
Many thanks !

I can't wait for a fix ^^
Keep up the good work.
« Last Edit: May 11, 2011, 06:23:34 PM by Thanatos00 »

Offline Olga Krovyakova

  • Users
  • *
  • Posts: 976
    • View Profile
Re: Issue with ingame recording
« Reply #4 on: May 10, 2011, 05:30:22 PM »
Hello Thanatos00,

Thanks for your reply.

We are working on this issue, I will inform you when we'll find a solution. 
I suppose it can take some time.
Regards,
Olga Krovyakova
Solveig Multimedia

Offline Thanatos00

  • Users
  • *
  • Posts: 3
    • View Profile
Re: Issue with ingame recording
« Reply #3 on: May 08, 2011, 07:55:40 PM »
Hi Olga,

Vertical synchronisation is already disabled ingame.
I think it's not a question of performance, cause ingame I have 125-130 fps without recording. When I try to record (and encode at the same time) a video I have ~80 fps ingame.

I've also test with 2 other games since I posted, and I have the same problem when the game is running in fullscreen mod.

I feel that this problem come from something about the way hypercam try to capture an appli in fullscreen mod.
I have exactly the same problem with other capture softwares that have a feature to capture only a part of the screen, but no problem with capture softwares that are fully dedicated to capture the entire screen (fraps, gamecam, Xfire, etc...).

I have also tried to configure hypercam to capture only a part of the screen, with the game in fullscreen mod -> sometimes when I tried to record, it seems hypercam interfere with the game : I sometimes see the red borders flashing over the game. It seems hypercam doesnt run quietly in the background without interfering with the game.
Maybe I dont really see it ingame cause my game is running fast enough, but hypercam captures these interferences it is causing to the game in fullscreen, as I'm recording with 30 fps...

I dont know, this is only supposition.
*I repeat that this problem disappears if I try to capture ingame session in "window mod".

Thanks anyway for your answer Olga.
Hope you or someone else of the HyperCam team will find a solution, or maybe an update/fix in the future if hypercam is causing the problem ?
I really would like to use HyperCam and all its very good features.

Regards.
« Last Edit: May 10, 2011, 10:28:23 PM by Thanatos00 »

Offline Olga Krovyakova

  • Users
  • *
  • Posts: 976
    • View Profile
Re: Issue with ingame recording
« Reply #2 on: May 06, 2011, 11:26:22 PM »
Hello Thanatos00,

Try to disable vertical synchronization on your PC.

This is the most trouble-free method of gaining the fastest possible performance. This is the simplest solution, and on monitors which have a standard 60Hz refresh rate, or for games in which your framerate is not consistently above 60FPS, this appears to be the best solution. You may notice some tearing, but this will generally be minimal if your FPS remains well below your refresh rate. Remember though that whenever VSync is disabled the graphics card and monitor are not strictly in sync, and tearing (however minor) may occur at any time.

Many games have the option to disable v-sync. Also, if you go to Start / Control Panel / Display Properties / Settings / Advanced there will be an option to disable V-Sync using your video card's driver software.

Assuming you are using Nvidia drivers, then, right click anywhere on the desktop.

 1) Choose properties.

 2) Go to settings.

 3) Choose advanced.

 4) Go to Open GL settings.

 5) Go to Vertical Sync.

 6) Select "disable"  or 'Switch off" Vsync.

 7) Apply


Please let me know if it will help you.
Regards,
Olga Krovyakova
Solveig Multimedia

Offline Thanatos00

  • Users
  • *
  • Posts: 3
    • View Profile
Issue with ingame recording
« Reply #1 on: May 05, 2011, 09:16:18 PM »
Hi,

Hypercam3 seems to have all features I'm searching in a video capture software :
-I need to capture and encode at the same time,
-to be able to capture the mouse pointer,
-to be able to choose the audio sound card source, etc...
So it's theoretically perfect for me!

Unfortunately I have a big issue when I want to record ingame videos (only tested with WoW).

My config :
Win Xp pro - Directx 9c - Nvidia GeForce GTS 450

Issue :
When I'm trying to capture a video of my desktop, no problem.
But when I try to do that ingame, I've no apparent issue when I'm recording, but on the video recorded all graphics (HUD and 3D objects) are flashing constantly...
Here an example of the problem (small capture of 7 sec, Xvid codec) : hyperCam3_ingame_bug_1280x1024.avi

Precisions :
-I've also tried other common codec, like divx, but same issue.
-I've absolutly no problem with fraps, gamecam, or FastCapPro that are fully dedicated to record ingame sessions (but these softwares arent good enough for me, they cant do what I want)
-I've got exactly the same problem with another soft (capture solution XE) that allow to capture only one part of the screen (I dont care about this feature, cause I want to record the full screen. But idk if it has a link with my problem).


I'm searching in vain a software that could allow me to do all what I want for ages... Hypercam3 have all the features I need, but I have this weird issue :(
Please can you help me to solve this ?


1000x thanks in advance.
Keep up the good work.

Regards.

Edit : Just tried to record with the game in "window mod", and it's working well. I think it's a problem with applications running in fullscreen mod. Any help ? Ty in advance.

2nd edit : today I've also submited this issue on the feedback page, here.
« Last Edit: May 06, 2011, 09:51:15 PM by Thanatos00 »