Author Topic: Problems with .mts files  (Read 704 times)

Offline Maxim.Sakhankov

  • Users
  • *
  • Posts: 241
    • View Profile
Re: Problems with .mts files
« Reply #2 on: December 20, 2018, 06:26:33 PM »
Hello waydown,

Could you please send your source file and a trimming project file to our technical support or to me directly? You can use any file sharing services.

Offline waydown

  • Users
  • *
  • Posts: 8
    • View Profile
Problems with .mts files
« Reply #1 on: December 04, 2018, 01:41:16 AM »
Greetings. Big fan of Video Splitter here, finally addressing an issue with DVB-T recordings / .mts files. As you know this is a common filetype when people record TV program, and I can imagine Video Splitter being a popular choice in order to trim the recordings by removing ads etc.
Most of the time, Video Splitter deals with them fine, sometimes there's warbled video or audio and minor artifacts. I'm not sure if there's a way to prevent those. But the main problem is that the program seems to do *something* during trimming and the resulting .mts file has problems upon trying to remux it into a mkv with programs like mkvtoolnix. I do this since .mkv is a more common and "user friendly" filetype between video player apps and media players in Smart TVs etc. without the problems that come with .mts sometimes.

So, it seems that each time there's a cut point, audio/video gets out of sync which is a big problem as you can imagine.
In each and every one of them, mkvmerge reports the following error:
"ts' track 1: This audio track contains 170 bytes of invalid data which were skipped before timestamp 00:06:53.024000000. The audio/video synchronization may have been lost".


"Obey sample times" ticked or unticked doesn't seem to make a difference and I have no idea how I could avoid it.
I know remuxing .mts to .mkv BEFORE trimming with Video Splitter, results in a more smooth editing process without problems but when you deal with a 10 gb recording for example, trimming the .mts saves you hard drive space and time since you don't have to remux to mkv beforehand. You can choose to remux the trimmed recording later but this is usually a much smaller file.
For example, there are times, I want to keep 5 mins of program from a 2h recording. When you have to work with multiple recordings, almost daily, as you can imagine something like that makes a big difference in hard drive space and time.
Is there anything I can do while trimming the .mts file so I don't get the audio/video sync problem while remuxing in .mkv? Maybe you could add mkv as an output option at some point, so no further remuxing in a separate program needed?
I hope there's a solution, I don't seem to get the same problem with programs like Smart Cutter but I like Video Trimmer much better and I'd prefer to work with that.  :)

Also, I have compiled a list with bugs/things to improve as well as new feature ideas, should I contact someone specifically?
Thanks.