Author Topic: Please help, can't get TS files render non-key frames in preview window  (Read 10003 times)
  • Administrator
  • Users
  • *****
  • Posts: 294
    • View Profile
Hello Nathalia,
The problem with the MPEG video preview while frame-stepping had been fixed in the latest beta (32-bit, 64-bit).

  • Administrator
  • Users
  • *****
  • Posts: 1169
    • View Profile
« Reply #3 on: September 23, 2016, 07:59:17 PM »
Hello Nathalia,

Thank you for your post!

This already known problem, it is in our "to do" list. As soon as it will be fixed, we will write at this thread.

If there will be any other suggestions or issue, please feel free to contact us.
Olga Krovyakova
Solveig Multimedia

  • Users
  • *
  • Posts: 3
    • View Profile
« Reply #2 on: September 23, 2016, 04:35:11 PM »
Just tried older
SolveigMM Video Splitter Home Edition
Installation version 4. 0. 1412. 10
Version 4. 0. 1409. 8
which works just fine on w10 x64 (pity there's no option to download it officialy via "previous versions" tab)
still, in preferences, "Smart Mode Settings", no "Chosen Codecs" is written and "Show filters for current file format" clears whole list, which implies it has nothing to do with this issue
I presume it uses some built-in codec which is fine for v4 but broken in newer versions of video splitter or frame stepping algo is messed up in newer versions

both v5 and v6 just can't do frame accurate preview on TS video files
tried versions:

there must be bug in newer versions, please take a look at it and fix it since I bought newer version in belief that all previous functionality is included and now I'm forced to use old version instead
« Last Edit: September 23, 2016, 04:59:33 PM by Nathalia »

  • Users
  • *
  • Posts: 3
    • View Profile
« Reply #1 on: September 23, 2016, 03:12:01 PM »
Hi all,
I'm desperate, not sure if it's video splitter 6 or win10 x64 problem:
as the subject states
I'm unable to get MPEG-2 TS file rendered with frame accuracy, keyframes render fine, non-keyframes do not render, preview always sticks to previous keyframe
tried many codecs, all "playback settings" in preferences,
in "smart mode settings" no codecs are chosen, no matter what I try
when I check "Show filters for current file format", all filters vanish
like what the hell, so many filters and none capable of rendering MPEG-2?
anyone else had this problem?
which codec do you suggest to install to get it work?
thank You all for the response, advise, anything ;)

I had no problem with v4 of video splitter on windows 7 x64, the same file
here's media info for file I'm trying to edit:
ID : 48 (0x30)
MenuID/String : 137 (0x89)
Formát : MPEG Video
Format_Version : Version 2
Format_Profile : Main@Main
Format_Settings_BVOP/String : Ano
Format_Settings_GOP : Variable
Format_Settings_PictureStructure : Frame
CodecID : 2
Duration/String : 1 h 29 min
Bit rate : 2 069 kb/s
BitRate_Maximum/String : 2 040 kb/s
Šířka : 720pixely
Výška : 576pixely
Poměr stran : 4:3
Frame rate : 25,000 FPS
Standard : PAL
ColorSpace : YUV
ChromaSubsampling/String : 4:2:0
BitDepth/String : 8 bits
ScanType/String : Interlaced
ScanOrder/String : Top Field First
Bits/(Pixel*Frame) : 0.200
StreamSize/String : 1,30 GiB (84%)
colour_primaries : BT.601 PAL
transfer_characteristics : BT.470 System B, BT.470 System G
matrix_coefficients : BT.601
« Last Edit: September 23, 2016, 03:14:37 PM by Nathalia »