Author Topic: MKV with VP9 video and Opus audio Crashes Videosplitter  (Read 8352 times)
  • Administrator
  • Users
  • *****
  • Posts: 301
    • View Profile
« Reply #4 on: July 07, 2017, 11:10:20 AM »
Hello birdy,

Thank you for the file, with the file I reproduced the described problem.
Unfortunately, at the moment Video Splitter does not support MKV files with VP9 video. We'll try to implement the support of such files in future releases and will let you know when the fix is ready.
« Last Edit: July 07, 2017, 12:07:28 PM by Maxim.Sakhankov »

  • Users
  • *
  • Posts: 8
    • View Profile
« Reply #3 on: July 07, 2017, 12:15:22 AM »
Hi Maxim,

Here is a link to one video file example: https://www.dropbox.com/s/fqmfn9zpbjdbaxx/Juliette%20Armanet%20-%20L%E2%80%99Amour%20en%20Solitaire%20-%20YouTube.MKV?dl=0

I choose a small size video for this example. But any video with VP9 video and Opus audio gives the same problem : "Unable to get source file length"
These MKV files have now become very popular as Youtube is using this compression method.



  • Administrator
  • Users
  • *****
  • Posts: 301
    • View Profile
« Reply #2 on: June 19, 2017, 11:27:02 AM »
Hello birdy,
Thank you very much for the feedback, we appreciate it a lot.

According to your problem, please send your problem file to our technical support - support(at)solveigmm(dot)com or to me directly.

  • Users
  • *
  • Posts: 8
    • View Profile
« Reply #1 on: June 16, 2017, 11:49:22 PM »
First of all congratulations for this great software. It's very effective and easy to use and supports many file types.
After long search and use of many other software this is THE ONLY ONE you should need to get the job done.

I have encountered a little problem with some MKV files (They have VP9 video and Opus audio). As soon as you open
the file you get an error message from videosplitter: "Unable to get source file length", and it will crash the software.

I was wondering if I was missing a 3rd party codec or if there is anything to be done on my side to fix the problem.
I can upload a sample video for you to test. But as an example any MKV video from youtube will result in the same error
as well. (for your information I am using SolveigMM Video Splitter on Windows10 pro.)

Looking forward to a response from the support team or any user who may have an answer to this :)
« Last Edit: June 16, 2017, 11:52:49 PM by birdy »