Author Topic: problem with very small cuts  (Read 16547 times)
  • Administrator
  • Users
  • *****
  • Posts: 875
    • View Profile
« Reply #6 on: April 18, 2012, 12:01:08 AM »
Thank you very much for the answer  :D

Frame accuracy editing is supported in Video Splitter.
http://www.solveigmm.com/en/products/video-splitter/
Regards,
Dmitry Vergeles
Solveig Multimedia

jane1909
  • Guest
« Reply #5 on: April 17, 2012, 11:15:17 PM »
Thank you very much for the answer  :D

  • Administrator
  • Users
  • *****
  • Posts: 1109
    • View Profile
« Reply #4 on: April 17, 2012, 07:07:53 PM »
Hello jane1909,

Thank you for file.

This issue is caused by the fact that AVI Trimmer + MKV edit AVI files in GOP (group of pictures) accurate mode.
It means that the program will only allow to cut the fragment from the key frame with which this group of pictures begins. The Key frame of the GOP is in the fragment that you have selected to be cutted off, but you want to cut the fragment that starts with the frame that is within this GOP.
The nearest key frame for your start position is on 00:11:960 therefore the trimming can be started only from this point - the key frame point, not from 00:14:400.

More information about this issue you can find here:
Inaccurate trimming
Regards,
Olga Krovyakova
Solveig Multimedia

jane1909
  • Guest
« Reply #3 on: April 15, 2012, 07:53:30 PM »
Hello again,

I've uploaded my video file at 4shared, and you can download it from this link:
Code: [Select]
http://www.4shared.com/video/mBGfE_qJ/Deset_zapovijedi_part2.html
It will ask you to register, I hope it won't be a problem :)

Waiting for your answer...

Bye

jane1909
  • Guest
« Reply #2 on: April 14, 2012, 03:21:21 AM »
Good evening  ;)

Thanks for the reply.
OK, I will upload the file, I think on 4shared, if not I'll let you know, and post a link when I do it, tomorrow or on Sunday.

This is not happening always, but sometimes. Maybe this would sound stupid, but it's just like one segment of the file doesn't want to be cutted off (for me, cut off means = I don't want to keep that fragment). This used to happen sometimes, but then I would just set a little bit more, 5-6 seconds to cut, and then it would cut it as I want, or a little bit that I don't want to cut. (excuse me if my English is bad for explaining).

I hope you'll understand on example of this file:
I need to cut off this: 00:00:00:000 - 00:00:14:400 and 00:39:29:000 - 00:39:31:360 (the very end of file), so I want to keep (save) just this one fragment: 00:00:14:400 - 00:39:29:000. What happens is this: it cuts off the first 11-12 seconds (and it should 14.400 sec) from the first selected fragment, and everything from the second fragment (just the way I wanted). Then I edit that saved (new) file again, and select to cut this segment of the file that wasn't cutted off (this 2-3 seconds), and the program does nothing. I mean, the program works, the progress comes to 100%, but with no result: the size and duration of the file is the same as the original. And when you play the video, you see that it is the same as the original one, and the fragments are not cutted off.

Thanks again  :)

jane1909

  • Administrator
  • Users
  • *****
  • Posts: 1109
    • View Profile
« Reply #1 on: April 13, 2012, 05:11:38 PM »
Hello jane1909,


Could you please upload you file to any file host service, e.g. to dropbox.com (provides 2 Gb  free space for file sharing)?

Please specify also start and stop time positions were chosen for your fragments.
Do all the fragments that you save have the duration and the size of the original video?

Regards,
Olga Krovyakova
Solveig Multimedia

jane1909
  • Guest
« on: April 12, 2012, 06:12:37 PM »
Hello guys,

SolveigMM AVI+MKV Trimmer works very well, but I'm having problem with cutting off very small parts (last about 5-6 seconds or less) of my video. It's a large (>800MB) .avi video, xvid video codec, mpeg 1 layer 3 (MP3) audio codec. The program does the progress to 100%, but the size and duration of the video is the same as the original one.
I've got Windows 7 Home Premium, K-Lite Codec Pack (full) 8.2. installed (and the newest Avi+Mkv Trimmer)

Please help me fix this problem